summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-07 23:13:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-07 23:13:06 +0000
commitc3f813a1da2767170e673e65831d3947b4da9c31 (patch)
tree2db40a33945d7867536f000c8c3438244b18bbf8 /dev-python/weberror
parentDelete older ebuild. (diff)
downloadgentoo-2-c3f813a1da2767170e673e65831d3947b4da9c31.tar.gz
gentoo-2-c3f813a1da2767170e673e65831d3947b4da9c31.tar.bz2
gentoo-2-c3f813a1da2767170e673e65831d3947b4da9c31.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/weberror')
-rw-r--r--dev-python/weberror/ChangeLog10
-rw-r--r--dev-python/weberror/weberror-0.10.2.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/weberror/ChangeLog b/dev-python/weberror/ChangeLog
index 02867acaaaae..856a883fdb9d 100644
--- a/dev-python/weberror/ChangeLog
+++ b/dev-python/weberror/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/weberror
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weberror/ChangeLog,v 1.1 2009/04/26 09:48:13 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weberror/ChangeLog,v 1.2 2010/06/07 23:13:06 arfrever Exp $
+
+*weberror-0.10.2 (07 Jun 2010)
+
+ 07 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -weberror-0.10.1.ebuild, +weberror-0.10.2.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*weberror-0.10.1 (26 Apr 2009)
diff --git a/dev-python/weberror/weberror-0.10.2.ebuild b/dev-python/weberror/weberror-0.10.2.ebuild
new file mode 100644
index 000000000000..c17d2abc040f
--- /dev/null
+++ b/dev-python/weberror/weberror-0.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weberror/weberror-0.10.2.ebuild,v 1.1 2010/06/07 23:13:06 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="WebError"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Web Error handling and exception catching"
+HOMEPAGE="http://pypi.python.org/pypi/WebError"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/paste-1.7.1
+ dev-python/pygments
+ dev-python/setuptools
+ dev-python/simplejson
+ dev-python/tempita
+ dev-python/webob"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"