summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-10 07:57:40 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-10 07:57:40 +0000
commit266282af3fff1d1876979def5000c2c41acb302b (patch)
tree1b7ffadd01bc120880c55594362c09d03bd1b982 /dev-python/webtest
parentVersion bump. (diff)
downloadgentoo-2-266282af3fff1d1876979def5000c2c41acb302b.tar.gz
gentoo-2-266282af3fff1d1876979def5000c2c41acb302b.tar.bz2
gentoo-2-266282af3fff1d1876979def5000c2c41acb302b.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog7
-rw-r--r--dev-python/webtest/webtest-2.0.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 6cd02ae681f9..c4fd72fd61fa 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.44 2013/02/15 19:36:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.45 2013/03/10 07:57:40 idella4 Exp $
+
+*webtest-2.0.1 (10 Mar 2013)
+
+ 10 Mar 2013; Ian Delaney <idella4@gentoo.org> +webtest-2.0.1.ebuild:
+ bump
*webtest-1.4.3-r1 (15 Feb 2013)
diff --git a/dev-python/webtest/webtest-2.0.1.ebuild b/dev-python/webtest/webtest-2.0.1.ebuild
new file mode 100644
index 000000000000..8de6c53fea86
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.1.ebuild,v 1.1 2013/03/10 07:57:40 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/webob-0.9.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Why is it so?
+ if [[ ${EPYTHON} == python3* ]]; then
+ rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}