summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-07-25 10:18:45 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-07-25 10:18:45 +0000
commitb2242de23ecb9e8093320c3f58ba98dc654f66cd (patch)
tree31f8e7e9feeafa37bb10032f77602a8ee65d57b3 /dev-python/werkzeug
parentVersion bump (diff)
downloadgentoo-2-b2242de23ecb9e8093320c3f58ba98dc654f66cd.tar.gz
gentoo-2-b2242de23ecb9e8093320c3f58ba98dc654f66cd.tar.bz2
gentoo-2-b2242de23ecb9e8093320c3f58ba98dc654f66cd.zip
Version bump werkzeug to 0.9.3.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/ChangeLog7
-rw-r--r--dev-python/werkzeug/werkzeug-0.9.3.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index 06969db33c6f..b192574c533b 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.41 2013/07/25 05:37:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.42 2013/07/25 10:18:45 djc Exp $
+
+*werkzeug-0.9.3 (25 Jul 2013)
+
+ 25 Jul 2013; Dirkjan Ochtman <djc@gentoo.org> +werkzeug-0.9.3.ebuild:
+ Version bump werkzeug to 0.9.3.
*werkzeug-0.9.2 (25 Jul 2013)
diff --git a/dev-python/werkzeug/werkzeug-0.9.3.ebuild b/dev-python/werkzeug/werkzeug-0.9.3.ebuild
new file mode 100644
index 000000000000..ab06f4aee557
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.9.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.9.3.ebuild,v 1.1 2013/07/25 10:18:45 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ http://pypi.python.org/pypi/Werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}