summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-05-29 12:51:03 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-05-29 12:51:03 +0000
commita64a98497decae44dc87ecc5a978dd15f5abc1d5 (patch)
tree4a97366bd691f89190e39275b24a7866b053ef6d /dev-python/wtforms
parentAdd 3.3 support for flask-login (bug 487898) (diff)
downloadgentoo-2-a64a98497decae44dc87ecc5a978dd15f5abc1d5.tar.gz
gentoo-2-a64a98497decae44dc87ecc5a978dd15f5abc1d5.tar.bz2
gentoo-2-a64a98497decae44dc87ecc5a978dd15f5abc1d5.zip
Remove old versions of wtforms
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog7
-rw-r--r--dev-python/wtforms/wtforms-0.6.3.ebuild56
-rw-r--r--dev-python/wtforms/wtforms-1.0.1.ebuild49
-rw-r--r--dev-python/wtforms/wtforms-1.0.2.ebuild49
-rw-r--r--dev-python/wtforms/wtforms-1.0.3-r1.ebuild42
-rw-r--r--dev-python/wtforms/wtforms-1.0.3.ebuild48
6 files changed, 6 insertions, 245 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index 33ce3b2c8ef0..f801cf59ab8e 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.36 2014/05/26 08:15:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.37 2014/05/29 12:51:03 djc Exp $
+
+ 29 May 2014; Dirkjan Ochtman <djc@gentoo.org> -wtforms-0.6.3.ebuild,
+ -wtforms-1.0.1.ebuild, -wtforms-1.0.2.ebuild, -wtforms-1.0.3-r1.ebuild,
+ -wtforms-1.0.3.ebuild:
+ Remove old versions of wtforms
*wtforms-2.0 (26 May 2014)
diff --git a/dev-python/wtforms/wtforms-0.6.3.ebuild b/dev-python/wtforms/wtforms-0.6.3.ebuild
deleted file mode 100644
index be1adbd0efb0..000000000000
--- a/dev-python/wtforms/wtforms-0.6.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.6.3.ebuild,v 1.3 2012/02/24 15:21:36 phajdan.jr Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_test() {
- cd tests
- testing() {
- "$(PYTHON)" runtests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/wtforms/wtforms-1.0.1.ebuild b/dev-python/wtforms/wtforms-1.0.1.ebuild
deleted file mode 100644
index ce5a31b3118c..000000000000
--- a/dev-python/wtforms/wtforms-1.0.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.1.ebuild,v 1.3 2012/05/21 09:33:28 phajdan.jr Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/wtforms/wtforms-1.0.2.ebuild b/dev-python/wtforms/wtforms-1.0.2.ebuild
deleted file mode 100644
index 0689f43f2101..000000000000
--- a/dev-python/wtforms/wtforms-1.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.2.ebuild,v 1.4 2013/03/25 20:52:07 ago Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/wtforms/wtforms-1.0.3-r1.ebuild b/dev-python/wtforms/wtforms-1.0.3-r1.ebuild
deleted file mode 100644
index fbaa5415922c..000000000000
--- a/dev-python/wtforms/wtforms-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.3-r1.ebuild,v 1.3 2014/03/31 20:54:48 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit distutils-r1
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/wtforms/wtforms-1.0.3.ebuild b/dev-python/wtforms/wtforms-1.0.3.ebuild
deleted file mode 100644
index 3dce7735c53b..000000000000
--- a/dev-python/wtforms/wtforms-1.0.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.3.ebuild,v 1.3 2013/05/20 08:28:08 ago Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-
-inherit distutils
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}