summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-13 19:54:38 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-13 19:54:38 +0000
commit807d80b04f009b9e52bc694fecd68226dbe49982 (patch)
treecdedd9a95faf29de920a9e31a27fe68d0d0a15cc /dev-python/wxPython
parentupdated KEYWORDS (diff)
downloadgentoo-2-807d80b04f009b9e52bc694fecd68226dbe49982.tar.gz
gentoo-2-807d80b04f009b9e52bc694fecd68226dbe49982.tar.bz2
gentoo-2-807d80b04f009b9e52bc694fecd68226dbe49982.zip
KEYWORD unmasking/prune older files
Diffstat (limited to 'dev-python/wxPython')
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.3.2.1-r21
-rw-r--r--dev-python/wxPython/files/ledctrl.diff60
-rw-r--r--dev-python/wxPython/files/noglcanvas.diff93
-rw-r--r--dev-python/wxPython/wxPython-2.3.2.1-r2.ebuild58
-rw-r--r--dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild13
5 files changed, 6 insertions, 219 deletions
diff --git a/dev-python/wxPython/files/digest-wxPython-2.3.2.1-r2 b/dev-python/wxPython/files/digest-wxPython-2.3.2.1-r2
deleted file mode 100644
index 2dac4ca0b00e..000000000000
--- a/dev-python/wxPython/files/digest-wxPython-2.3.2.1-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e57b4d030c4ba43a9030fdaee083011c wxPython-2.3.2.1.tar.gz 2845829
diff --git a/dev-python/wxPython/files/ledctrl.diff b/dev-python/wxPython/files/ledctrl.diff
deleted file mode 100644
index c86e08cc34bd..000000000000
--- a/dev-python/wxPython/files/ledctrl.diff
+++ /dev/null
@@ -1,60 +0,0 @@
---- ledctrl.cpp Thu Aug 29 12:36:52 2002
-+++ ledctrl.cpp-cvs Thu Aug 29 12:36:22 2002
-@@ -134,6 +134,7 @@
- {
- if (Value != m_Value)
- {
-+#ifdef __WXDEBUG__
- if (!Value.IsEmpty())
- {
- for(size_t i=0; i<Value.Length(); i++) {
-@@ -142,6 +143,7 @@
- wxT("wxLEDNumberCtrl can only display numeric string values."));
- }
- }
-+#endif
-
- m_Value = Value;
- RecalcInternals(GetClientSize());
-@@ -191,7 +193,7 @@
- DrawDigit(MemDc, DIGITALL, i);
-
- // Draw the digits.
-- switch (m_Value[i])
-+ switch (m_Value.GetChar(i))
- {
- case '0' :
- DrawDigit(MemDc, DIGIT0, i);
-@@ -230,7 +232,7 @@
- // just skip it
- break;
- default :
-- wxFAIL_MSG(_("Unknown digit value"));
-+ wxFAIL_MSG(wxT("Unknown digit value"));
- break;
- }
- }
-@@ -318,12 +320,12 @@
- if ((Height * 0.07) < 1)
- m_LineMargin = 1;
- else
-- m_LineMargin = Height * 0.07;
-+ m_LineMargin = (int)(Height * 0.07);
-
- if ((Height * 0.35) < 1)
- m_LineLength = 1;
- else
-- m_LineLength = Height * 0.35;
-+ m_LineLength = (int)(Height * 0.35);
-
- m_LineWidth = m_LineMargin;
-
-@@ -344,7 +346,7 @@
- m_LeftStartPos = (ClientWidth - ValueWidth) / 2;
- break;
- default :
-- wxFAIL_MSG(_("Unknown alignent value for wxLEDNumberCtrl."));
-+ wxFAIL_MSG(wxT("Unknown alignent value for wxLEDNumberCtrl."));
- break;
- }
- }
diff --git a/dev-python/wxPython/files/noglcanvas.diff b/dev-python/wxPython/files/noglcanvas.diff
deleted file mode 100644
index cfd4ebff7838..000000000000
--- a/dev-python/wxPython/files/noglcanvas.diff
+++ /dev/null
@@ -1,93 +0,0 @@
-diff -urN wxPython-2.3.2.1/setup.py wxPython-2.3.2.1-modified/setup.py
---- wxPython-2.3.2.1/setup.py Thu Dec 20 11:33:42 2001
-+++ wxPython-2.3.2.1-modified/setup.py Thu Aug 22 14:04:04 2002
-@@ -28,7 +28,7 @@
- """
-
-
--BUILD_GLCANVAS = 1 # If true, build the contrib/glcanvas extension module
-+BUILD_GLCANVAS = 0 # If true, build the contrib/glcanvas extension module
- BUILD_OGL = 1 # If true, build the contrib/ogl extension module
- BUILD_STC = 1 # If true, build the contrib/stc extension module
- BUILD_XRC = 1 # XML based resource system
-@@ -435,43 +435,43 @@
- #----------------------------------------------------------------------
- # Define the GLCanvas extension module
- #----------------------------------------------------------------------
--
--CTRB_SRC = opj(WXDIR, 'contrib/src')
--CTRB_INC = opj(WXDIR, 'contrib/include/wx')
--
--if BUILD_GLCANVAS or GL_ONLY:
-- msg('Preparing GLCANVAS...')
-- location = 'contrib/glcanvas'
-- swig_files = ['glcanvas.i']
-- other_sources = []
--
-- swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
-- USE_SWIG, swig_force, swig_args)
--
-- gl_libs = []
-- if os.name == 'posix':
-- gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
-- gl_lflags = string.split(gl_config) + lflags
-- gl_libs = libs
-- else:
-- other_sources = [opj(location, 'msw/myglcanvas.cpp')]
-- gl_libs = libs + ['opengl32', 'glu32']
-- gl_lflags = lflags
--
-- ext = Extension('glcanvasc',
-- swig_sources + other_sources,
--
-- include_dirs = includes,
-- define_macros = defines,
--
-- library_dirs = libdirs,
-- libraries = gl_libs,
--
-- extra_compile_args = cflags,
-- extra_link_args = gl_lflags,
-- )
--
-- wxpExtensions.append(ext)
-+#
-+#CTRB_SRC = opj(WXDIR, 'contrib/src')
-+#CTRB_INC = opj(WXDIR, 'contrib/include/wx')
-+#
-+#if BUILD_GLCANVAS or GL_ONLY:
-+# msg('Preparing GLCANVAS...')
-+# location = 'contrib/glcanvas'
-+# swig_files = ['glcanvas.i']
-+# other_sources = []
-+#
-+# swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
-+# USE_SWIG, swig_force, swig_args)
-+#
-+# gl_libs = []
-+# if os.name == 'posix':
-+# gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
-+# gl_lflags = string.split(gl_config) + lflags
-+# gl_libs = libs
-+# else:
-+# other_sources = [opj(location, 'msw/myglcanvas.cpp')]
-+# gl_libs = libs + ['opengl32', 'glu32']
-+# gl_lflags = lflags
-+#
-+# ext = Extension('glcanvasc',
-+# swig_sources + other_sources,
-+#
-+# include_dirs = includes,
-+# define_macros = defines,
-+#
-+# library_dirs = libdirs,
-+# libraries = gl_libs,
-+#
-+# extra_compile_args = cflags,
-+# extra_link_args = gl_lflags,
-+# )
-+#
-+# wxpExtensions.append(ext)
-
-
- #----------------------------------------------------------------------
diff --git a/dev-python/wxPython/wxPython-2.3.2.1-r2.ebuild b/dev-python/wxPython/wxPython-2.3.2.1-r2.ebuild
deleted file mode 100644
index 809a88f7ac64..000000000000
--- a/dev-python/wxPython/wxPython-2.3.2.1-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.2.1-r2.ebuild,v 1.10 2002/12/09 04:21:13 manson Exp $
-
-IUSE="opengl"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="A blending of the wxWindows C++ class library with Python."
-SRC_URI="mirror://sourceforge/wxpython/${P}.tar.gz"
-HOMEPAGE="http://www.wxpython.org/"
-
-DEPEND=">=dev-lang/python-2.1
- =dev-libs/glib-1.2*
- =x11-libs/gtk+-1.2*
- =x11-libs/wxGTK-2.3.2*
- opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="x86 ppc sparc alpha"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}/contrib/gizmos/contrib/src/gizmos
- patch -p0 < ${FILESDIR}/ledctrl.diff || die "patch failed"
- cd ${S}
-
-}
-
-src_compile() {
-
- local myconf
- myconf=""
-
-#Other possible configuration variables are BUILD_OGL and BUILD_STC.
-#BUILD_OGL builds the Object Graphics Library extension module.
-#BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
-#Both these variable are enabled by default. To disable them set equal to zero
-#and add to myconf.
-
- if use opengl; then
- myconf="${myconf} BUILD_GLCANVAS=1"
- else
- myconf="${myconf} BUILD_GLCANVAS=0"
- patch -p1 < ${FILESDIR}/noglcanvas.diff || die "patch failed"
- fi
-
- python setup.py ${myconf} build || die
-}
-
-src_install () {
-
- python setup.py ${myconf} install --prefix=${D}/usr || die
-
- dodoc BUILD.unix.txt CHANGES.txt MANIFEST.in PKG-INFO README.txt
-}
diff --git a/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild b/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild
index 15955626c271..591293390d0e 100644
--- a/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild
+++ b/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild,v 1.3 2002/12/09 04:21:13 manson Exp $
-
-IUSE="opengl"
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild,v 1.4 2002/12/13 19:54:38 vapier Exp $
MY_P="${P/-/Src-}"
S="${WORKDIR}/${MY_P}/${PN}"
@@ -10,16 +8,17 @@ DESCRIPTION="A blending of the wxWindows C++ class library with Python."
SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
HOMEPAGE="http://www.wxpython.org/"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE="opengl"
+
DEPEND=">=dev-lang/python-2.1
=dev-libs/glib-1.2*
=x11-libs/gtk+-1.2*
=x11-libs/wxGTK-2.3.3*
opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
-
pkg_setup() {
# xfree should not install these, remove until the fixed
# xfree is in main use.