summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-07-28 22:56:25 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-07-28 22:56:25 +0000
commit07f989bf037286f1d846bb48863392f90e183e16 (patch)
tree29af601752f0fa8f484cf6812b580812d2c558e5 /dev-python/wxpython
parentVersion bump, remove old. (diff)
downloadgentoo-2-07f989bf037286f1d846bb48863392f90e183e16.tar.gz
gentoo-2-07f989bf037286f1d846bb48863392f90e183e16.tar.bz2
gentoo-2-07f989bf037286f1d846bb48863392f90e183e16.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog8
-rw-r--r--dev-python/wxpython/files/wxpython-2.9.4.1-wxversion-scripts.patch211
-rw-r--r--dev-python/wxpython/wxpython-2.9.4.1.ebuild154
3 files changed, 372 insertions, 1 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index ab3f5da46910..2f86a64605e5 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.169 2012/07/28 22:42:59 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.170 2012/07/28 22:56:25 dirtyepic Exp $
+
+*wxpython-2.9.4.1 (28 Jul 2012)
+
+ 28 Jul 2012; Ryan Hill <dirtyepic@gentoo.org> +wxpython-2.9.4.1.ebuild,
+ +files/wxpython-2.9.4.1-wxversion-scripts.patch:
+ Version bump.
28 Jul 2012; Ryan Hill <dirtyepic@gentoo.org> -wxpython-2.8.11.0.ebuild,
-files/wxpython-2.8.11-drop-editra.patch, -wxpython-2.8.12.0.ebuild,
diff --git a/dev-python/wxpython/files/wxpython-2.9.4.1-wxversion-scripts.patch b/dev-python/wxpython/files/wxpython-2.9.4.1-wxversion-scripts.patch
new file mode 100644
index 000000000000..7067af9eee79
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.9.4.1-wxversion-scripts.patch
@@ -0,0 +1,211 @@
+--- a/distrib/PyAlaMode.desktop
++++ b/distrib/PyAlaMode.desktop
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PyAlaMode
++Name=PyAlaMode (2.9)
+ Comment=GUI Python Shell with Filling and editor windows
+-Exec=pyalamode
+-Icon=PyCrust
++Exec=pyalamode-2.9
++Icon=PyCrust-2.9
+ Terminal=false
+ Type=Application
+ Categories=Development;
+--- a/distrib/PyCrust.desktop
++++ b/distrib/PyCrust.desktop
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PyCrust
++Name=PyCrust (2.9)
+ Comment=GUI Python Shell with Filling
+-Exec=pycrust
+-Icon=PyCrust
++Exec=pycrust-2.9
++Icon=PyCrust-2.9
+ Terminal=false
+ Type=Application
+ Categories=Development;
+--- a/distrib/PyShell.desktop
++++ b/distrib/PyShell.desktop
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PyShell
++Name=PyShell (2.9)
+ Comment=GUI Python Shell
+-Exec=pyshell
+-Icon=PyCrust
++Exec=pyshell-2.9
++Icon=PyCrust-2.9
+ Terminal=false
+ Type=Application
+ Categories=Development;
+--- a/distrib/PySlices.desktop
++++ b/distrib/PySlices.desktop
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PySlices
++Name=PySlices (2.9)
+ Comment=GUI Python Shell with Filling
+-Exec=pyslices
+-Icon=PySlices
++Exec=pyslices-2.9
++Icon=PySlices-2.9
+ Terminal=false
+ Type=Application
+ Categories=Development;
+--- a/distrib/PySlicesShell.desktop
++++ b/distrib/PySlicesShell.desktop
+@@ -1,9 +1,8 @@
+-
+ [Desktop Entry]
+-Name=PySlicesShell
++Name=PySlicesShell (2.9)
+ Comment=GUI Python Shell
+-Exec=pysliceshell
+-Icon=PySlices
++Exec=pysliceshell-2.9
++Icon=PySlices-2.9
+ Terminal=false
+ Type=Application
+ Categories=Development;
+--- a/distrib/XRCed.desktop
++++ b/distrib/XRCed.desktop
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=XRCed
++Name=XRCed (2.9)
+ Comment=wxPython XRC resource editor
+-Exec=xrced
+-Icon=XRCed
++Exec=xrced-2.9
++Icon=XRCed-2.9
+ Terminal=false
+ Type=Application
+ Categories=Development;
+--- a/scripts/genaxmodule
++++ b/scripts/genaxmodule
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.genaxmodule import main
+ main()
+--- a/scripts/helpviewer
++++ b/scripts/helpviewer
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.helpviewer import main
+ main()
+--- a/scripts/img2png
++++ b/scripts/img2png
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.img2png import main
+ main()
+--- a/scripts/img2py
++++ b/scripts/img2py
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.img2py import main
+ main()
+--- a/scripts/img2xpm
++++ b/scripts/img2xpm
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.img2xpm import main
+ main()
+--- a/scripts/pyalacarte
++++ b/scripts/pyalacarte
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PyAlaCarte import main
+ main()
+--- a/scripts/pyalamode
++++ b/scripts/pyalamode
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PyAlaMode import main
+ main()
+--- a/scripts/pycrust
++++ b/scripts/pycrust
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PyCrust import main
+ main()
+--- a/scripts/pyshell
++++ b/scripts/pyshell
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PyShell import main
+ main()
+--- a/scripts/pyslices
++++ b/scripts/pyslices
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PySlices import main
+ main()
+--- a/scripts/pysliceshell
++++ b/scripts/pysliceshell
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PySlicesShell import main
+ main()
+--- a/scripts/pywrap
++++ b/scripts/pywrap
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.py.PyWrap import main
+ main()
+--- a/scripts/pywxrc
++++ b/scripts/pywxrc
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.pywxrc import main
+ main()
+--- a/scripts/xrced
++++ b/scripts/xrced
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.9")
+
+ from wx.tools.XRCed.xrced import main
+ main()
diff --git a/dev-python/wxpython/wxpython-2.9.4.1.ebuild b/dev-python/wxpython/wxpython-2.9.4.1.ebuild
new file mode 100644
index 000000000000..dc9445c53341
--- /dev/null
+++ b/dev-python/wxpython/wxpython-2.9.4.1.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1.ebuild,v 1.1 2012/07/28 22:56:25 dirtyepic Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+WX_GTK_VER="2.9"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython 2.7-pypy-*"
+
+inherit alternatives distutils eutils fdo-mime wxwidgets
+
+MY_PN="wxPython-src"
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_PN}-2.9.4.0.tar.bz2
+ examples? ( mirror://sourceforge/wxpython/wxPython-demo-2.9.4.0.tar.bz2 )
+ mirror://sourceforge/wxpython/${MY_PN}-2.9.4.1.patch"
+
+LICENSE="wxWinLL-3"
+SLOT="2.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cairo examples opengl"
+
+RDEPEND="
+ >=x11-libs/wxGTK-${PV}:${WX_GTK_VER}[opengl?,tiff,X]
+ dev-libs/glib:2
+ dev-python/setuptools
+ media-libs/libpng:0
+ media-libs/tiff:0
+ virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/pango[X]
+ cairo? ( >=dev-python/pycairo-1.8.4 )
+ opengl? ( dev-python/pyopengl )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-2.9.4.0/wxPython"
+DOC_S="${WORKDIR}/wxPython-2.9.4.0"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing")
+
+PYTHON_MODNAME="wx-${PV%.*}-gtk2 wxversion.py"
+
+src_prepare() {
+ sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+
+ cd ..
+ epatch "${DISTDIR}"/${MY_PN}-${PV}.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-wxversion-scripts.patch
+ # drop editra - we have it as a separate package now
+ epatch "${FILESDIR}"/${PN}-2.8.11-drop-editra.patch
+
+ if use examples; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-demo.patch
+ fi
+
+ python_copy_sources
+}
+
+src_configure() {
+ need-wxwidgets unicode
+
+ DISTUTILS_GLOBAL_OPTIONS=(
+ "* WX_CONFIG=${WX_CONFIG}"
+ "* WXPORT=gtk2"
+ "* UNICODE=1"
+ "* BUILD_GLCANVAS=$(use opengl && echo 1 || echo 0)"
+ )
+}
+
+distutils_src_install_post_hook() {
+ # Collision protection.
+ local file
+ for file in "$(distutils_get_intermediate_installation_image)${EPREFIX}"/usr/bin/*; do
+ mv "${file}" "${file}-${SLOT}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ local file x
+ # Collision protection.
+ rename_files() {
+ for file in "${D}$(python_get_sitedir)/"wx{version.*,.pth}; do
+ mv "${file}" "${file}-${SLOT}" || return 1
+ done
+ }
+ python_execute_function -q rename_files
+
+ dodoc "${S}"/docs/{CHANGES,PyManual,README,wxPackage,wxPythonManual}.txt
+
+ insinto /usr/share/applications
+ for x in {Py{AlaMode,Crust,Shell},XRCed}; do
+ newins "${S}"/distrib/${x}.desktop ${x}-${SLOT}.desktop
+ done
+ insinto /usr/share/pixmaps
+ newins "${S}"/wx/py/PyCrust_32.png PyCrust-${SLOT}.png
+ newins "${S}"/wx/py/PySlices_32.png PySlices-${SLOT}.png
+ newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed-${SLOT}.png
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/demo
+ dodir /usr/share/doc/${PF}/samples
+ cp -R "${DOC_S}"/demo/* "${D}"/usr/share/doc/${PF}/demo/ || die
+ cp -R "${DOC_S}"/samples/* "${D}"/usr/share/doc/${PF}/samples/ || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ create_symlinks() {
+ alternatives_auto_makesym "$(python_get_sitedir)/wx.pth" "$(python_get_sitedir)/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym "$(python_get_sitedir)/wxversion.py" "$(python_get_sitedir)/wxversion.py-[0-9].[0-9]"
+ }
+ python_execute_function -q create_symlinks
+
+ distutils_pkg_postinst
+
+ echo
+ elog "Gentoo uses the Multi-version method for SLOT'ing."
+ elog "Developers, see this site for instructions on using"
+ elog "2.8 or 2.9 with your apps:"
+ elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ elog
+ if use examples; then
+ elog "The demo.py app which contains demo modules with"
+ elog "documentation and source code has been installed at"
+ elog "/usr/share/doc/${PF}/demo/demo.py"
+ elog
+ elog "More example apps and modules can be found in"
+ elog "/usr/share/doc/${PF}/samples/"
+ fi
+ echo
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+
+ create_symlinks() {
+ alternatives_auto_makesym "$(python_get_sitedir)/wx.pth" "$(python_get_sitedir)/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym "$(python_get_sitedir)/wxversion.py" "$(python_get_sitedir)/wxversion.py-[0-9].[0-9]"
+ }
+ python_execute_function -q create_symlinks
+}