summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-01-18 08:06:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-01-18 08:06:07 +0000
commit64889a3cfa98052704a8d57dea5a647dac068dce (patch)
tree9a88cbef587fccae2d67e32af2142a11adf24023 /dev-python/wxpython
parentBump to 2.24.3 - lots of bug fixes. Dropping icaltz-util.patch since this has... (diff)
downloadgentoo-2-64889a3cfa98052704a8d57dea5a647dac068dce.tar.gz
gentoo-2-64889a3cfa98052704a8d57dea5a647dac068dce.tar.bz2
gentoo-2-64889a3cfa98052704a8d57dea5a647dac068dce.zip
Integrate dev-python/wxpython-docs into wxpython ebuild for bug #230305.
Remove old and drop all keywords except arm, sh, and x86-fbsd on the 2.6.4.0 ebuild. (Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog15
-rw-r--r--dev-python/wxpython/files/wxpython-2.8-cache-writable.patch20
-rw-r--r--dev-python/wxpython/files/wxpython-2.8-wxversion-demo.patch10
-rw-r--r--dev-python/wxpython/metadata.xml4
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild133
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.8.9.1-r3.ebuild (renamed from dev-python/wxpython/wxpython-2.8.7.1.ebuild)83
7 files changed, 112 insertions, 159 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 499977a9f3c2..2a9bd0fead34 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-python/wxpython
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.107 2008/11/26 02:20:19 dirtyepic Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.108 2009/01/18 08:06:06 dirtyepic Exp $
+
+*wxpython-2.8.9.1-r3 (18 Jan 2009)
+
+ 18 Jan 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxpython-2.8-cache-writable.patch,
+ +files/wxpython-2.8-wxversion-demo.patch, metadata.xml,
+ wxpython-2.6.4.0.ebuild, -wxpython-2.6.4.0-r1.ebuild,
+ -wxpython-2.8.7.1.ebuild, +wxpython-2.8.9.1-r3.ebuild:
+ Integrate dev-python/wxpython-docs into wxpython ebuild for bug #230305.
+ Remove old and drop all keywords except arm, sh, and x86-fbsd on the
+ 2.6.4.0 ebuild.
*wxpython-2.8.9.1-r2 (26 Nov 2008)
diff --git a/dev-python/wxpython/files/wxpython-2.8-cache-writable.patch b/dev-python/wxpython/files/wxpython-2.8-cache-writable.patch
new file mode 100644
index 000000000000..57f26b37c2e8
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8-cache-writable.patch
@@ -0,0 +1,20 @@
+Use /tmp for cache files since the user won't have
+write permissions on ${DOCDIR}.
+
+diff -Naurp docs-orig/viewdocs.py docs/viewdocs.py
+--- docs-orig/viewdocs.py 2008-09-28 15:59:16.000000000 -0600
++++ docs/viewdocs.py 2009-01-18 00:16:27.000000000 -0600
+@@ -16,11 +16,11 @@ if not basePath:
+
+
+ # test for write access
+-if os.access(basePath, os.W_OK):
++if os.access('/tmp', os.W_OK):
+
+ # setup the args
+ args = ['',
+- '--cache='+basePath,
++ '--cache=/tmp',
+ os.path.join(basePath, 'wx.zip'),
+ ]
+
diff --git a/dev-python/wxpython/files/wxpython-2.8-wxversion-demo.patch b/dev-python/wxpython/files/wxpython-2.8-wxversion-demo.patch
new file mode 100644
index 000000000000..97829198a0b2
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8-wxversion-demo.patch
@@ -0,0 +1,10 @@
+--- demo/demo.org 2005-04-28 03:00:13.431583384 +0000
++++ demo/demo.py 2005-04-28 03:00:31.886777768 +0000
+@@ -1,4 +1,7 @@
+ #!/usr/bin/env python
+
++import wxversion
++wxversion.select("2.8")
++
+ import Main
+ Main.main()
diff --git a/dev-python/wxpython/metadata.xml b/dev-python/wxpython/metadata.xml
index 0b4cfd384556..ba15621fe582 100644
--- a/dev-python/wxpython/metadata.xml
+++ b/dev-python/wxpython/metadata.xml
@@ -3,4 +3,8 @@
<pkgmetadata>
<herd>wxwidgets</herd>
<herd>python</herd>
+<use>
+ <flag name="examples">Install interactive demo module browser and sample applets.</flag>
+ <flag name="doc">Install HTML wxWidgets docs and wxpython API reference.</flag>
+</use>
</pkgmetadata>
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
deleted file mode 100644
index d69deb290b7e..000000000000
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.16 2008/07/28 22:59:02 dirtyepic Exp $
-
-EAPI=1
-
-inherit alternatives eutils multilib python wxwidgets flag-o-matic
-
-# Note, we don't use distutils.eclass because it doesn't seem to play nice with
-# need-wxwidgets
-
-MY_P="${P/wxpython-/wxPython-src-}"
-DESCRIPTION="A blending of the wxWindows C++ class library with Python"
-HOMEPAGE="http://www.wxpython.org/"
-SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
-
-LICENSE="wxWinLL-3"
-SLOT="2.6"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="opengl unicode"
-
-RDEPEND=">=dev-lang/python-2.1
- >=x11-libs/wxGTK-${PV}:2.6
- >=x11-libs/gtk+-2.0
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0
- media-libs/libpng
- media-libs/jpeg
- media-libs/tiff
- >=sys-libs/zlib-1.1.4
- opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}/wxPython/"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
- epatch "${FILESDIR}"/scripts-multiver-2.6.1.0.diff
-}
-
-src_compile() {
- local mypyconf
- WX_GTK_VER="2.6"
-
- if use unicode; then
- need-wxwidgets unicode
- else
- need-wxwidgets ansi
- fi
-
- use opengl && check_wxuse opengl
-
- append-flags -fno-strict-aliasing
-
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- use unicode \
- && mypyconf="${mypyconf} UNICODE=1" \
- || mypyconf="${mypyconf} UNICODE=0"
-
- mypyconf="${mypyconf} WXPORT=gtk2"
-
- python setup.py ${mypyconf} build || die "setup.py build failed"
-}
-
-src_install() {
- local mypyconf
- python_version
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
- use unicode \
- && mypyconf="${mypyconf} UNICODE=1" \
- || mypyconf="${mypyconf} UNICODE=0"
-
- mypyconf="${mypyconf} WXPORT=gtk2"
-
- python setup.py ${mypyconf} install --root="${D}" \
- --install-purelib ${site_pkgs} || die "setup.py install failed"
-
- # Collision protection.
- for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
- mv "${file}" "${file}-${SLOT}"
- done
-
- for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
- if [[ -d ${dir} ]]; then
- cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
- wxaddons_copied=1
- fi
- done
-
- [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
-}
-
-pkg_postinst() {
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- python_mod_optimize ${size_pkgs}
-
- alternatives_auto_makesym \
- "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
- alternatives_auto_makesym \
- "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
-
- echo
- elog "Gentoo uses the Multi-version method for SLOT'ing."
- elog "Developers see this site for instructions on using 2.6 or 2.8"
- elog "with your apps:"
- elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
- echo
-}
-
-pkg_postrm() {
- python_mod_cleanup
-
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- alternatives_auto_makesym \
- "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
- alternatives_auto_makesym \
- "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
-}
diff --git a/dev-python/wxpython/wxpython-2.6.4.0.ebuild b/dev-python/wxpython/wxpython-2.6.4.0.ebuild
index f0464139bc3d..37d70bf41a1e 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0.ebuild,v 1.14 2008/07/28 21:43:11 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0.ebuild,v 1.15 2009/01/18 08:06:06 dirtyepic Exp $
inherit python wxwidgets eutils multilib flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
LICENSE="wxWinLL-3"
SLOT="2.6"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+KEYWORDS="arm sh ~x86-fbsd"
IUSE="unicode opengl"
RDEPEND=">=dev-lang/python-2.1
diff --git a/dev-python/wxpython/wxpython-2.8.7.1.ebuild b/dev-python/wxpython/wxpython-2.8.9.1-r3.ebuild
index 604d7f578912..a7e609f9c53b 100644
--- a/dev-python/wxpython/wxpython-2.8.7.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.9.1-r3.ebuild
@@ -1,64 +1,74 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.13 2008/07/28 22:59:02 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.9.1-r3.ebuild,v 1.1 2009/01/18 08:06:06 dirtyepic Exp $
-EAPI="1"
+EAPI="2"
WX_GTK_VER="2.8"
inherit alternatives eutils multilib python wxwidgets flag-o-matic
-
-# Note, we don't use distutils.eclass because it doesn't seem to play nice with
+# We don't use distutils.eclass because it doesn't seem to play nice with
# need-wxwidgets
MY_P="${P/wxpython-/wxPython-src-}"
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
HOMEPAGE="http://www.wxpython.org/"
-SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2
+ doc? ( mirror://sourceforge/wxpython/wxPython-docs-${PV}.tar.bz2
+ mirror://sourceforge/wxpython/wxPython-newdocs-${PV}.tar.bz2 )
+ examples? ( mirror://sourceforge/wxpython/wxPython-demo-${PV}.tar.bz2 )"
LICENSE="wxWinLL-3"
SLOT="2.8"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="opengl"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cairo opengl doc examples"
-RDEPEND=">=dev-lang/python-2.1
- >=x11-libs/wxGTK-${PV}:2.8
+RDEPEND=">=x11-libs/wxGTK-${PV}:2.8[opengl?]
+ >=dev-lang/python-2.4
>=x11-libs/gtk+-2.4
>=x11-libs/pango-1.2
>=dev-libs/glib-2.0
media-libs/libpng
media-libs/jpeg
media-libs/tiff
+ cairo? ( dev-python/pycairo )
opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
S="${WORKDIR}/${MY_P}/wxPython/"
+DOC_S="${WORKDIR}/wxPython-${PV}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
- epatch "${FILESDIR}"/${PN}-2.8.7-wxversion-scripts.patch
+ epatch "${FILESDIR}"/${PN}-2.8.8-wxversion-scripts.patch
-}
+ if use doc; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-cache-writable.patch
+ fi
-src_compile() {
- local mypyconf
+ if use examples; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-demo.patch
+ fi
+}
+src_configure() {
need-wxwidgets unicode
- use opengl && check_wxuse opengl
append-flags -fno-strict-aliasing
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
|| mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+}
+src_compile() {
python setup.py ${mypyconf} build || die "setup.py build failed"
}
@@ -90,6 +100,20 @@ src_install() {
done
[[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
+
+ dodoc "${S}"/docs/{CHANGES,PyManual,README,wxPackage,wxPythonManual}.txt
+
+ if use doc; then
+ dodir /usr/share/doc/${PF}/docs
+ cp -R "${DOC_S}"/docs/* "${D}"usr/share/doc/${PF}/docs/
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/demo
+ dodir /usr/share/doc/${PF}/samples
+ cp -R "${DOC_S}"/demo/* "${D}"/usr/share/doc/${PF}/demo/
+ cp -R "${DOC_S}"/samples/* "${D}"/usr/share/doc/${PF}/samples/
+ fi
}
pkg_postinst() {
@@ -104,9 +128,26 @@ pkg_postinst() {
echo
elog "Gentoo uses the Multi-version method for SLOT'ing."
- elog "Developers see this site for instructions on using 2.6 or 2.8"
- elog "with your apps:"
+ elog "Developers, see this site for instructions on using"
+ elog "2.6 or 2.8 with your apps:"
elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ elog
+ if use doc; then
+ elog "To access the general wxWidgets documentation,"
+ elog "run /usr/share/doc/${PF}/docs/viewdocs.py"
+ elog
+ elog "wxPython documentation is available by pointing a browser"
+ elog "at /usr/share/doc/${PF}/docs/api/index.html"
+ elog
+ fi
+ if use examples; then
+ elog "The demo.py app which contains hundreds of demo modules"
+ elog "with documentation and source code has been installed at"
+ elog "/usr/share/doc/${PF}/demo/demo.py"
+ elog
+ elog "Many more example apps and modules can be found in"
+ elog "/usr/share/doc/${PF}/samples/"
+ fi
echo
}