summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-05 09:36:33 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-05 09:36:33 +0000
commitbf24385cc803aaf7c61e3df2afd416e293b805c2 (patch)
treeca2029e66abd5f1fbec2c2448c2f68aa1ef37815 /dev-python/wxpython
parentUse doicon instead insinto + doins to install icon files (diff)
downloadgentoo-2-bf24385cc803aaf7c61e3df2afd416e293b805c2.tar.gz
gentoo-2-bf24385cc803aaf7c61e3df2afd416e293b805c2.tar.bz2
gentoo-2-bf24385cc803aaf7c61e3df2afd416e293b805c2.zip
Use doicon instead insinto + doins to install icon files
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1.ebuild7
-rw-r--r--dev-python/wxpython/wxpython-2.9.3.1.ebuild9
-rw-r--r--dev-python/wxpython/wxpython-2.9.4.1.ebuild9
4 files changed, 16 insertions, 15 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 0ec2519f3bfb..9d90ecd268c2 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.172 2012/09/05 07:40:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.173 2012/09/05 09:36:33 jlec Exp $
+
+ 05 Sep 2012; Justin Lecher <jlec@gentoo.org> wxpython-2.8.12.1.ebuild,
+ wxpython-2.9.3.1.ebuild, wxpython-2.9.4.1.ebuild:
+ Use doicon instead insinto + doins to install icon files
05 Sep 2012; Justin Lecher <jlec@gentoo.org> wxpython-2.8.12.1.ebuild,
wxpython-2.9.3.1.ebuild, wxpython-2.9.4.1.ebuild:
diff --git a/dev-python/wxpython/wxpython-2.8.12.1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
index fdf30e454caa..9ecda054eaec 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.16 2012/09/05 07:40:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.17 2012/09/05 09:36:33 jlec Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -105,9 +105,8 @@ src_install() {
dodoc "${S}"/docs/{CHANGES,PyManual,README,wxPackage,wxPythonManual}.txt
domenu "${S}"/distrib/{Py{AlaMode,Crust,Shell},XRCed}.desktop
- insinto /usr/share/pixmaps
- newins "${S}"/wx/py/PyCrust_32.png PyCrust.png
- newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed.png
+ newicon "${S}"/wx/py/PyCrust_32.png PyCrust.png
+ newicon "${S}"/wx/tools/XRCed/XRCed_32.png XRCed.png
docdir=${D}usr/share/doc/${PF}
diff --git a/dev-python/wxpython/wxpython-2.9.3.1.ebuild b/dev-python/wxpython/wxpython-2.9.3.1.ebuild
index 699c07de1ec9..79e4ab7ba233 100644
--- a/dev-python/wxpython/wxpython-2.9.3.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.9.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.3.1.ebuild,v 1.4 2012/09/05 07:40:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.3.1.ebuild,v 1.5 2012/09/05 09:36:33 jlec Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -101,10 +101,9 @@ src_install() {
for x in {Py{AlaMode,Crust,Shell,Slices{,Shell}},XRCed}; do
newmenu "${S}"/distrib/${x}.desktop ${x}-${SLOT}.desktop
done
- insinto /usr/share/pixmaps
- newins "${S}"/wx/py/PyCrust_32.png PyCrust-${SLOT}.png
- newins "${S}"/wx/py/PySlices_32.png PySlices-${SLOT}.png
- newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed-${SLOT}.png
+ newicon "${S}"/wx/py/PyCrust_32.png PyCrust-${SLOT}.png
+ newicon "${S}"/wx/py/PySlices_32.png PySlices-${SLOT}.png
+ newicon "${S}"/wx/tools/XRCed/XRCed_32.png XRCed-${SLOT}.png
if use examples; then
dodir /usr/share/doc/${PF}/demo
diff --git a/dev-python/wxpython/wxpython-2.9.4.1.ebuild b/dev-python/wxpython/wxpython-2.9.4.1.ebuild
index f679abfd568c..445687416cb6 100644
--- a/dev-python/wxpython/wxpython-2.9.4.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.9.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1.ebuild,v 1.2 2012/09/05 07:40:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1.ebuild,v 1.3 2012/09/05 09:36:33 jlec Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -100,10 +100,9 @@ src_install() {
for x in {Py{AlaMode,Crust,Shell},XRCed}; do
newmenu "${S}"/distrib/${x}.desktop ${x}-${SLOT}.desktop
done
- insinto /usr/share/pixmaps
- newins "${S}"/wx/py/PyCrust_32.png PyCrust-${SLOT}.png
- newins "${S}"/wx/py/PySlices_32.png PySlices-${SLOT}.png
- newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed-${SLOT}.png
+ newicon "${S}"/wx/py/PyCrust_32.png PyCrust-${SLOT}.png
+ newicon "${S}"/wx/py/PySlices_32.png PySlices-${SLOT}.png
+ newicon "${S}"/wx/tools/XRCed/XRCed_32.png XRCed-${SLOT}.png
if use examples; then
dodir /usr/share/doc/${PF}/demo