summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-03-03 09:52:25 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-03-03 09:52:25 +0000
commit8abd0764d15bee6872945db541b2398fa5083516 (patch)
tree54332a5948f88bc2c6c902acb4b6f1b49a638b88 /dev-python/xlrd
parentUse system tlslite instead of the bundled one. (diff)
downloadgentoo-2-8abd0764d15bee6872945db541b2398fa5083516.tar.gz
gentoo-2-8abd0764d15bee6872945db541b2398fa5083516.tar.bz2
gentoo-2-8abd0764d15bee6872945db541b2398fa5083516.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/ChangeLog9
-rw-r--r--dev-python/xlrd/xlrd-0.7.3.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/xlrd/ChangeLog b/dev-python/xlrd/ChangeLog
index 6d9e5ebff694..3720f843caef 100644
--- a/dev-python/xlrd/ChangeLog
+++ b/dev-python/xlrd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xlrd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.2 2010/07/13 13:07:13 jmbsvicetto Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.3 2012/03/03 09:52:25 nelchael Exp $
+
+*xlrd-0.7.3 (03 Mar 2012)
+
+ 03 Mar 2012; Krzysztof Pawlik <nelchael@gentoo.org> +xlrd-0.7.3.ebuild:
+ Version bump.
13 Jul 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/dev-python/xlrd/xlrd-0.7.3.ebuild b/dev-python/xlrd/xlrd-0.7.3.ebuild
new file mode 100644
index 000000000000..909a9ed6f5f5
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/xlrd-0.7.3.ebuild,v 1.1 2012/03/03 09:52:25 nelchael Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+ # add shebang to runxlrd.py
+ sed -i -e '1i#!/usr/bin/env python' scripts/runxlrd.py || die
+}