summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-06-13 12:40:04 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-06-13 12:40:04 +0000
commit021871ee5ee7499ecb0b71af912bffc90da0b1f5 (patch)
treeb6e61672abd5e667a30620f8d7a7f51a4edc7fe4 /dev-python
parentRemove Apache1. (diff)
downloadgentoo-2-021871ee5ee7499ecb0b71af912bffc90da0b1f5.tar.gz
gentoo-2-021871ee5ee7499ecb0b71af912bffc90da0b1f5.tar.bz2
gentoo-2-021871ee5ee7499ecb0b71af912bffc90da0b1f5.zip
Remove Apache1.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mod_python/ChangeLog6
-rw-r--r--dev-python/mod_python/files/digest-mod_python-2.7.113
-rw-r--r--dev-python/mod_python/mod_python-2.7.11.ebuild57
3 files changed, 5 insertions, 61 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index 76a325a39ae0..b04621c5d428 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.57 2007/06/08 06:05:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.58 2007/06/13 12:40:04 chtekk Exp $
+
+ 13 Jun 2007; Luca Longinotti <chtekk@gentoo.org>
+ -mod_python-2.7.11.ebuild:
+ Remove Apache1.
08 Jun 2007; Joshua Kinard <kumba@gentoo.org> mod_python-3.3.1.ebuild:
Marked unstable on mips, per #181068.
diff --git a/dev-python/mod_python/files/digest-mod_python-2.7.11 b/dev-python/mod_python/files/digest-mod_python-2.7.11
deleted file mode 100644
index b2410baf5f1f..000000000000
--- a/dev-python/mod_python/files/digest-mod_python-2.7.11
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 edea9de6c6273c1e0df8df4b10d247aa mod_python-2.7.11.tgz 175763
-RMD160 1b34de01b3fa4bb27bb5a39396a2497db66fabd5 mod_python-2.7.11.tgz 175763
-SHA256 d56f21b37a85c6f2464b669faf071676302d636037fccf818722291126e851cf mod_python-2.7.11.tgz 175763
diff --git a/dev-python/mod_python/mod_python-2.7.11.ebuild b/dev-python/mod_python/mod_python-2.7.11.ebuild
deleted file mode 100644
index a6c75dac3c86..000000000000
--- a/dev-python/mod_python/mod_python-2.7.11.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.11.ebuild,v 1.6 2007/01/15 19:59:55 chtekk Exp $
-
-inherit python apache-module multilib
-
-KEYWORDS="~amd64 x86"
-
-DESCRIPTION="An Apache1 module providing an embedded Python interpreter."
-HOMEPAGE="http://www.modpython.org/"
-SRC_URI="mirror://apache/httpd/modpython/${P}.tgz"
-LICENSE="as-is"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-lang/python"
-RDEPEND="${DEPEND}"
-
-APACHE1_MOD_CONF="16_${PN}"
-APACHE1_MOD_DEFINE="PYTHON"
-
-DOCFILES="COPYRIGHT CREDITS NEWS README"
-
-need_apache1
-
-src_compile() {
- # If we dont add that, ./configure breaks this ebuild
- # because the last task (make depend) is somehow borked
- echo 'echo "configure done"' >> configure
-
- sed -ie 's:OPT=:OPT=$(OPTFLAGS):' "${S}/src/Makefile.in"
- sed -ie 's/\(\\"thread\\" in sys.builtin_module_names\)/int(\1)/' "${S}/configure"
-
- export OPTFLAGS="`/usr/sbin/apxs -q CFLAGS` -fPIC"
- econf --with-apxs=${APXS1} || die "econf failed"
-
- sed -ie 's:LIBEXECDIR=:LIBEXECDIR=${D}:' "Makefile"
- sed -ie 's:PY_STD_LIB=:PY_STD_LIB=${D}:' "Makefile"
- sed -ie 's:CFLAGS=$(OPT) $(INCLUDES):CFLAGS=$(OPT) $(INCLUDES) -DEAPI -O0:' "${S}/src/Makefile"
- emake || die "emake failed"
-}
-
-src_install() {
- python_version
- PY_LIBPATH="/usr/$(get_libdir)/python${PYVER}"
- dodir "${PY_LIBPATH}"
-
- # compileall.py is needed or make install will fail
- cp -f "${PY_LIBPATH}/compileall.py" "${D}${PY_LIBPATH}/compileall.py"
- emake DESTDIR="${D}" install || die "emake install failed"
- rm -f "${D}${PY_LIBPATH}/compileall.py"
-
- insinto "/usr/share/doc/${PF}/html"
- doins -r doc-html/*
-
- apache-module_src_install
-}