summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-04-18 17:09:46 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-04-18 17:09:46 +0000
commit0a250a1e2768500aa16a003e1a3e9dca89a56eef (patch)
tree270288a46563e08ca0a11562b7c66de86eba4459 /dev-python
parentClosing #48058. (Manifest recommit) (diff)
downloadgentoo-2-0a250a1e2768500aa16a003e1a3e9dca89a56eef.tar.gz
gentoo-2-0a250a1e2768500aa16a003e1a3e9dca89a56eef.tar.bz2
gentoo-2-0a250a1e2768500aa16a003e1a3e9dca89a56eef.zip
Added fPIC patch.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Imaging/ChangeLog5
-rw-r--r--dev-python/Imaging/Imaging-1.1.4.ebuild9
-rw-r--r--dev-python/Imaging/files/Imaging-1.1.4-fPIC.patch11
3 files changed, 19 insertions, 6 deletions
diff --git a/dev-python/Imaging/ChangeLog b/dev-python/Imaging/ChangeLog
index 0abaff44f0ec..1fe3c155f431 100644
--- a/dev-python/Imaging/ChangeLog
+++ b/dev-python/Imaging/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/Imaging
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/ChangeLog,v 1.15 2004/03/28 13:25:15 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/ChangeLog,v 1.16 2004/04/18 17:09:46 aliz Exp $
+
+ 18 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> Imaging-1.1.4.ebuild:
+ Created -fPIC patch instead of adding fPIC to CFLAGS.
28 Mar 2004; Bryan Østergaard <kloeri@gentoo.org> Imaging-1.1.2-r2.ebuild,
Imaging-1.1.3-r1.ebuild, Imaging-1.1.3-r2.ebuild, Imaging-1.1.3.ebuild:
diff --git a/dev-python/Imaging/Imaging-1.1.4.ebuild b/dev-python/Imaging/Imaging-1.1.4.ebuild
index f5808d13d268..854eca191120 100644
--- a/dev-python/Imaging/Imaging-1.1.4.ebuild
+++ b/dev-python/Imaging/Imaging-1.1.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/Imaging-1.1.4.ebuild,v 1.10 2004/04/06 03:03:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/Imaging-1.1.4.ebuild,v 1.11 2004/04/18 17:09:46 aliz Exp $
-inherit distutils flag-o-matic
+inherit distutils eutils
DESCRIPTION="Python Imaging Library (PIL)"
HOMEPAGE="http://www.pythonware.com/products/pil/index.htm"
@@ -21,12 +21,11 @@ DEPEND="virtual/python
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 setup.py < ${FILESDIR}/${P}-setup.py.patch || die
+ epatch ${FILESDIR}/${P}-setup.py.patch
+ epatch ${FILESDIR}/${P}-fPIC.patch
}
src_compile() {
- append-flags -fPIC
-
export OPT=${CFLAGS}
#Build the core imaging library (libImaging.a)
diff --git a/dev-python/Imaging/files/Imaging-1.1.4-fPIC.patch b/dev-python/Imaging/files/Imaging-1.1.4-fPIC.patch
new file mode 100644
index 000000000000..f39e0870bf4c
--- /dev/null
+++ b/dev-python/Imaging/files/Imaging-1.1.4-fPIC.patch
@@ -0,0 +1,11 @@
+--- libImaging/Makefile.in 2004-04-18 16:53:00.242241087 +0000
++++ libImaging/Makefile.in 2004-04-18 17:02:49.245737559 +0000
+@@ -128,5 +128,8 @@
+
+ # --------------------------------------------------------------------
+
++%.o: %.c
++ ${CC} ${CFLAGS} -fPIC -c $< -o $@
++
+ # DO NOT DELETE THIS LINE -- mkdep uses it.
+ # DO NOT PUT ANYTHING AFTER THIS LINE, IT WILL GO AWAY.