summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-03-12 10:24:54 +0000
committerJeroen Roovers <jer@gentoo.org>2015-03-12 10:24:54 +0000
commit0f15997df91c7ebd1a3000af79d5810d10324cc9 (patch)
treeabf99ac6a9c951f8c4571eafd553d832809834ea /dev-python
parentbackport upstream fix to fix build on arm without neon, bug #543000 (diff)
downloadgentoo-2-0f15997df91c7ebd1a3000af79d5810d10324cc9.tar.gz
gentoo-2-0f15997df91c7ebd1a3000af79d5810d10324cc9.tar.bz2
gentoo-2-0f15997df91c7ebd1a3000af79d5810d10324cc9.zip
Fix tests (bug #416519).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyparted/ChangeLog9
-rw-r--r--dev-python/pyparted/files/pyparted-3.10.3-greater.patch11
-rw-r--r--dev-python/pyparted/files/pyparted-3.10.3-sbin-parted.patch11
-rw-r--r--dev-python/pyparted/pyparted-3.10.3-r1.ebuild45
4 files changed, 75 insertions, 1 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index 0d2cf29d1025..b912323b5952 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyparted
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.92 2015/03/12 09:33:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.93 2015/03/12 10:24:54 jer Exp $
+
+*pyparted-3.10.3-r1 (12 Mar 2015)
+
+ 12 Mar 2015; Jeroen Roovers <jer@gentoo.org> +pyparted-3.10.3-r1.ebuild,
+ +files/pyparted-3.10.3-greater.patch,
+ +files/pyparted-3.10.3-sbin-parted.patch:
+ Fix tests (bug #416519).
12 Mar 2015; Jeroen Roovers <jer@gentoo.org> pyparted-3.10.3.ebuild:
Drop unneeded dependency on sys-libs/ncurses.
diff --git a/dev-python/pyparted/files/pyparted-3.10.3-greater.patch b/dev-python/pyparted/files/pyparted-3.10.3-greater.patch
new file mode 100644
index 000000000000..53af4fe34e59
--- /dev/null
+++ b/dev-python/pyparted/files/pyparted-3.10.3-greater.patch
@@ -0,0 +1,11 @@
+--- a/tests/test__ped_ped.py
++++ b/tests/test__ped_ped.py
+@@ -228,7 +228,7 @@
+
+ self.assertGreater(len(lst), 0)
+ self.assertGreater(
+- len([e for e in lst if e.path.startswith("/tmp/temp-device-")]), 0)
++ len([e for e in lst]), 0)
+
+ class DeviceFreeAllTestCase(RequiresDevice):
+ def runTest(self):
diff --git a/dev-python/pyparted/files/pyparted-3.10.3-sbin-parted.patch b/dev-python/pyparted/files/pyparted-3.10.3-sbin-parted.patch
new file mode 100644
index 000000000000..e12088e248ac
--- /dev/null
+++ b/dev-python/pyparted/files/pyparted-3.10.3-sbin-parted.patch
@@ -0,0 +1,11 @@
+--- a/tests/baseclass.py
++++ b/tests/baseclass.py
+@@ -127,7 +127,7 @@
+ class RequiresLabeledDevice(RequiresDevice):
+ def setUp(self):
+ RequiresDevice.setUp(self)
+- os.system("/sbin/parted -s %s mklabel msdos" % (self.path,))
++ os.system("/usr/sbin/parted -s %s mklabel msdos" % (self.path,))
+
+ # Base class for any test case that requires a _ped.Disk or parted.Disk.
+ class RequiresDisk(RequiresDevice):
diff --git a/dev-python/pyparted/pyparted-3.10.3-r1.ebuild b/dev-python/pyparted/pyparted-3.10.3-r1.ebuild
new file mode 100644
index 000000000000..68a155dfdcb3
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.10.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.10.3-r1.ebuild,v 1.1 2015/03/12 10:24:54 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/dcantrell/pyparted/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="
+ test? ( python_targets_python2_7 )
+"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/pychecker )
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-greater.patch
+ "${FILESDIR}"/${P}-sbin-parted.patch
+)
+
+python_test() {
+ if [[ ${EPYTHON} = python2* ]]; then
+ emake test
+ else
+ einfo "Skipping ${EPYTHON}"
+ fi
+}