summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-04-19 06:43:37 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-04-19 06:43:37 +0000
commit0fb893d4f9d386eb7b8019e4e8d7651bdda0ffb5 (patch)
treea8c2717d9f94bf936ce3606bd02b0583eacde378 /dev-python
parentfixed wrong defined append- flag, reported by M.D.Buerkle on wrt bug 508054 (diff)
downloadgentoo-2-0fb893d4f9d386eb7b8019e4e8d7651bdda0ffb5.tar.gz
gentoo-2-0fb893d4f9d386eb7b8019e4e8d7651bdda0ffb5.tar.bz2
gentoo-2-0fb893d4f9d386eb7b8019e4e8d7651bdda0ffb5.zip
bump to 0.8.0
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pbr/ChangeLog8
-rw-r--r--dev-python/pbr/pbr-0.8.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/pbr/ChangeLog b/dev-python/pbr/ChangeLog
index c85a01bf48a6..928b385aac04 100644
--- a/dev-python/pbr/ChangeLog
+++ b/dev-python/pbr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pbr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.13 2014/03/30 06:08:46 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.14 2014/04/19 06:43:37 prometheanfire Exp $
+
+*pbr-0.8.0 (19 Apr 2014)
+
+ 19 Apr 2014; Matthew Thode <prometheanfire@gentoo.org> +pbr-0.8.0.ebuild,
+ pbr-0.7.0.ebuild:
+ bump to 0.8.0
30 Mar 2014; Ian Delaney <idella4@gentoo.org> -pbr-0.5.21.ebuild,
-pbr-0.5.23-r1.ebuild, pbr-0.7.0.ebuild:
diff --git a/dev-python/pbr/pbr-0.8.0.ebuild b/dev-python/pbr/pbr-0.8.0.ebuild
new file mode 100644
index 000000000000..4d0803245cbe
--- /dev/null
+++ b/dev-python/pbr/pbr-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.8.0.ebuild,v 1.1 2014/04/19 06:43:37 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )"
+RDEPEND=">dev-python/pip-1.4[${PYTHON_USEDEP}]"
+
+# Requ'd for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+# You can do this in about 3 different ways; throw it in a src_test() and prepend it to a
+# distutils-r1_src_test or os it a distutils-r1_python_test, but really it makes for a HUGE 'meh'
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ sed -e s':test_console_script_develop:_&:' -i pbr/tests/test_core.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run || die "Testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "Run over tests folder by flake8 drew error"
+}