summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-23 15:08:57 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-23 15:08:57 +0000
commit0fc13fef7954c916c3ad294f7b9280c25d326c7b (patch)
tree071ee8f9154591670b539f0dea7fd1a804c72b20 /dev-python
parentAdd support for ruby20. (diff)
downloadgentoo-2-0fc13fef7954c916c3ad294f7b9280c25d326c7b.tar.gz
gentoo-2-0fc13fef7954c916c3ad294f7b9280c25d326c7b.tar.bz2
gentoo-2-0fc13fef7954c916c3ad294f7b9280c25d326c7b.zip
rebuild whole migration, missing test phase added, resticted until 1 final issue resolved, wrt Bug #474360
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pywebkitgtk/ChangeLog6
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild46
2 files changed, 47 insertions, 5 deletions
diff --git a/dev-python/pywebkitgtk/ChangeLog b/dev-python/pywebkitgtk/ChangeLog
index b9ed5e411c39..ec1137318c0d 100644
--- a/dev-python/pywebkitgtk/ChangeLog
+++ b/dev-python/pywebkitgtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pywebkitgtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.29 2013/06/22 08:31:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.30 2013/06/23 15:08:57 idella4 Exp $
+
+ 23 Jun 2013; Ian Delaney <idella4@gentoo.org> pywebkitgtk-1.1.8-r1.ebuild:
+ rebuild whole migration, missing test phase added, resticted until 1 final
+ issue resolved, wrt Bug #474360
*pywebkitgtk-1.1.8-r1 (22 Jun 2013)
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
index 5d90425d3f05..350bf3623887 100644
--- a/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
+++ b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild,v 1.1 2013/06/22 08:31:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild,v 1.2 2013/06/23 15:08:57 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -14,7 +14,7 @@ SRC_URI="http://pywebkitgtk.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
+IUSE="test"
RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
dev-python/pygtk:2[${PYTHON_USEDEP}]
@@ -24,7 +24,45 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS MAINTAINERS NEWS README )
+RESTRICT="test"
-python_configure_all() {
- python_configure_all --disable-static
+src_prepare() {
+ python_copy_sources
+}
+
+src_configure() {
+ config() {
+ econf --disable-static
+ }
+#ECONF_SOURCE="{S}" econf --disable-static
+ python_parallel_foreach_impl run_in_build_dir config
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir emake
+}
+
+# Need fix a dbus session issue run as root
+src_test() {
+ testing() {
+ local test
+ pushd webkit > /dev/null
+ ln -sf ../webkit.la . || die
+ ln -sf ../.libs/webkit.so . || die
+ popd > /dev/null
+ for test in tests/test_*.py
+ do
+ if ! PYTHONPATH=. "${PYTHON}" ${test}; then
+ die "Test ${test} failed under ${EPYTHON}"
+ fi
+ done
+ einfo "Testsuite passed under ${EPYTHON}"
+ # rm symlinks
+ rm -f webkit/{webkit.la,webkit.so}
+ }
+ python_foreach_impl run_in_build_dir testing
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
}