summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-02 06:56:38 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-02 06:56:38 +0000
commit1413e5e2e01b7cd424cd9211825a9bb0e2049d6e (patch)
treee08f3e52dbfe5bf5979fdbc88df0352c2dfd15cf /dev-python
parentMerge live/non-live ebuilds, fix up USE="-client -server" behavior, and handl... (diff)
downloadgentoo-2-1413e5e2e01b7cd424cd9211825a9bb0e2049d6e.tar.gz
gentoo-2-1413e5e2e01b7cd424cd9211825a9bb0e2049d6e.tar.bz2
gentoo-2-1413e5e2e01b7cd424cd9211825a9bb0e2049d6e.zip
New package.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/certifi/ChangeLog10
-rw-r--r--dev-python/certifi/Manifest3
-rw-r--r--dev-python/certifi/certifi-0.0.6.ebuild31
-rw-r--r--dev-python/certifi/metadata.xml5
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/certifi/ChangeLog b/dev-python/certifi/ChangeLog
new file mode 100644
index 000000000000..530fb5c3f7b2
--- /dev/null
+++ b/dev-python/certifi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/certifi
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/certifi/ChangeLog,v 1.1 2012/01/02 06:56:38 floppym Exp $
+
+*certifi-0.0.6 (02 Jan 2012)
+
+ 02 Jan 2012; Mike Gilbert <floppym@gentoo.org> +certifi-0.0.6.ebuild,
+ +metadata.xml:
+ New package.
+
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
new file mode 100644
index 000000000000..0b32c434fbeb
--- /dev/null
+++ b/dev-python/certifi/Manifest
@@ -0,0 +1,3 @@
+DIST certifi-0.0.6.tar.gz 118451 RMD160 65827de13f51cb9127d1b5a8097698dd074f6320 SHA1 aca0de0c545b95d528ce413ef1560108da1cf46e SHA256 e839718ce80daa9853b1f47a333757d4a22cdf422e2fd8de5e579d5634a89585
+EBUILD certifi-0.0.6.ebuild 696 RMD160 e17267888a31d6ba3f95c17016ffeb6c96041d1e SHA1 3445473b679f99c4e555b593a73e9daaf8d01b1d SHA256 3fe6b7b9038ef3706beaf23eaaad026df5c1ccbf48f1af75487fc71322340981
+MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/certifi/certifi-0.0.6.ebuild b/dev-python/certifi/certifi-0.0.6.ebuild
new file mode 100644
index 000000000000..69518335980b
--- /dev/null
+++ b/dev-python/certifi/certifi-0.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/certifi/certifi-0.0.6.ebuild,v 1.1 2012/01/02 06:56:38 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="SSL root certificate bundle"
+HOMEPAGE="http://python-requests.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/ca-certificates"
+
+src_install() {
+ distutils_src_install
+ installing() {
+ # Overwrite bundled certificates with a symlink.
+ dosym "${EPREFIX}/etc/ssl/certs/ca-certificates.crt" \
+ "$(python_get_sitedir -b)/certifi/cacert.pem"
+ }
+ python_execute_function installing
+}
diff --git a/dev-python/certifi/metadata.xml b/dev-python/certifi/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/certifi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>