summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-08 14:33:13 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-08 14:33:13 +0000
commit2903e46e5c9b868bff0441c3122d7510dcb437c5 (patch)
tree72070edc5d545ee3184e7f9ec1556e29ffd7d225 /dev-python
parentVersion bump (diff)
downloadgentoo-2-2903e46e5c9b868bff0441c3122d7510dcb437c5.tar.gz
gentoo-2-2903e46e5c9b868bff0441c3122d7510dcb437c5.tar.bz2
gentoo-2-2903e46e5c9b868bff0441c3122d7510dcb437c5.zip
migration revbump, added missing test phase
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ujson/ChangeLog8
-rw-r--r--dev-python/ujson/ujson-1.30-r1.ebuild39
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/ujson/ChangeLog b/dev-python/ujson/ChangeLog
index 4bcab90f5109..1e0c800774dd 100644
--- a/dev-python/ujson/ChangeLog
+++ b/dev-python/ujson/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-python/ujson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ujson/ChangeLog,v 1.1 2013/02/24 09:56:11 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ujson/ChangeLog,v 1.2 2013/04/08 14:33:13 idella4 Exp $
+
+*ujson-1.30-r1 (08 Apr 2013)
+
+ 08 Apr 2013; Ian Delaney <idella4@gentoo.org> +ujson-1.30-r1.ebuild:
+ migration revbump, added missing test phase
*ujson-1.30 (24 Feb 2013)
24 Feb 2013; Sven Wegener <swegener@gentoo.org> +ujson-1.30.ebuild,
+metadata.xml:
Initial commit, ebuild written by me.
-
diff --git a/dev-python/ujson/ujson-1.30-r1.ebuild b/dev-python/ujson/ujson-1.30-r1.ebuild
new file mode 100644
index 000000000000..8f8c2199e561
--- /dev/null
+++ b/dev-python/ujson/ujson-1.30-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ujson/ujson-1.30-r1.ebuild,v 1.1 2013/04/08 14:33:13 idella4 Exp $
+
+EAPI="5"
+
+# One test; FAIL: test_encodeToUTF8 (__main__.UltraJSONTests) under py2.5.
+# Fix and repair and re-insert if it's REALLY needed
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="http://pypi.python.org/pypi/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ # See setup.py; line 72. Again "${S}" is used for reading tests
+ # Since py3_2 is first in the queue it needs its own copy
+ # or else all py2s to follow will be reading read py3 tests
+ if [[ "${EPYTHON}" == 'python3.2' ]]; then
+ cd "${BUILD_DIR}"/lib || die
+ cp -a "${S}"/tests/ . || die
+ 2to3 -w tests/tests.py
+ "${PYTHON}" tests/tests.py || die
+ rm -rf tests/ || die
+ else
+ "${PYTHON}" tests/tests.py || die
+ fi
+}