summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-03-06 10:06:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-03-06 10:06:04 +0000
commit2c8d94e6b1eeda71792eb08cd45b19a41ed2a08f (patch)
tree347a87783fc804f5f9c18d0ccb17f9a7414f109a /dev-python
parentBumping gentoo-sources to 2.6.18.8. (diff)
downloadgentoo-2-2c8d94e6b1eeda71792eb08cd45b19a41ed2a08f.tar.gz
gentoo-2-2c8d94e6b1eeda71792eb08cd45b19a41ed2a08f.tar.bz2
gentoo-2-2c8d94e6b1eeda71792eb08cd45b19a41ed2a08f.zip
don't check for cblas when flag lapack unused. allows F77FLAGS.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numpy/ChangeLog7
-rw-r--r--dev-python/numpy/numpy-1.0.1-r1.ebuild20
2 files changed, 17 insertions, 10 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index f507c36b3a7c..5b23dc2267fe 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.20 2007/03/05 10:39:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.21 2007/03/06 10:06:04 bicatali Exp $
+
+ 06 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ numpy-1.0.1-r1.ebuild:
+ Fixed a cblas requirement when lapack was not called. Allows F77FLAGS to
+ be used along FFLAGS for FORTRAN flags.
05 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org>
+files/numpy-1.0.1-cpuinfo.patch, numpy-1.0.1-r1.ebuild:
diff --git a/dev-python/numpy/numpy-1.0.1-r1.ebuild b/dev-python/numpy/numpy-1.0.1-r1.ebuild
index 458fa1d38d13..f5c53f3ee6e2 100644
--- a/dev-python/numpy/numpy-1.0.1-r1.ebuild
+++ b/dev-python/numpy/numpy-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.0.1-r1.ebuild,v 1.3 2007/03/05 10:39:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.0.1-r1.ebuild,v 1.4 2007/03/06 10:06:04 bicatali Exp $
NEED_PYTHON=2.3
@@ -30,15 +30,17 @@ FORTRAN="g77 gfortran"
numpy_configure() {
local mycblas
- for d in $(eselect cblas show); do mycblas=${d}; done
- if [[ -z "${mycblas/reference/}" ]] && [[ -z "${mycblas/atlas/}" ]]; then
- ewarn "You need to set cblas to atlas or reference. Do:"
- ewarn " eselect cblas set <impl>"
- ewarn "where <impl> is atlas, threaded-atlas or reference"
- die "setup failed"
+ if use lapack; then
+ for d in $(eselect cblas show); do mycblas=${d}; done
+ if [[ -z "${mycblas/reference/}" ]] && [[ -z "${mycblas/atlas/}" ]]; then
+ ewarn "You need to set cblas to atlas or reference. Do:"
+ ewarn " eselect cblas set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
fi
-
- [[ -z "${FFLAGS}" ]] && FFLAGS="${CFLAGS}"
+ [[ -z "${F77FLAGS}" ]] && F77FLAGS="${CFLAGS}"
+ [[ -z "${FFLAGS}" ]] && FFLAGS="${F77FLAGS}"
# remove default values
echo "# gentoo config" > site.cfg