summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-01 23:13:51 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-01 23:13:51 +0000
commit3a04a8f62917352bac0a514bbd39708d8cbe2eb9 (patch)
tree406616f6f0456bdaa53104a71558d08868f41bf9 /dev-python
parentBackport some improvements from the newer ebuild. Fix python_test(). Do not r... (diff)
downloadgentoo-2-3a04a8f62917352bac0a514bbd39708d8cbe2eb9.tar.gz
gentoo-2-3a04a8f62917352bac0a514bbd39708d8cbe2eb9.tar.bz2
gentoo-2-3a04a8f62917352bac0a514bbd39708d8cbe2eb9.zip
Fix python_test() to reference PYTHON properly. Remove redundant swig call.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydvdread/ChangeLog7
-rw-r--r--dev-python/pydvdread/pydvdread-1.0-r1.ebuild16
2 files changed, 8 insertions, 15 deletions
diff --git a/dev-python/pydvdread/ChangeLog b/dev-python/pydvdread/ChangeLog
index c77a7191d78e..c4152878d97f 100644
--- a/dev-python/pydvdread/ChangeLog
+++ b/dev-python/pydvdread/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pydvdread
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydvdread/ChangeLog,v 1.2 2014/07/02 03:02:40 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydvdread/ChangeLog,v 1.3 2015/01/01 23:13:51 mgorny Exp $
+
+ 01 Jan 2015; Michał Górny <mgorny@gentoo.org> pydvdread-1.0-r1.ebuild:
+ Fix python_test() to reference PYTHON properly. Remove redundant swig call.
*pydvdread-1.0-r1 (02 Jul 2014)
diff --git a/dev-python/pydvdread/pydvdread-1.0-r1.ebuild b/dev-python/pydvdread/pydvdread-1.0-r1.ebuild
index 8a563f9b4b8f..8d89ced0fe15 100644
--- a/dev-python/pydvdread/pydvdread-1.0-r1.ebuild
+++ b/dev-python/pydvdread/pydvdread-1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydvdread/pydvdread-1.0-r1.ebuild,v 1.1 2014/07/02 03:02:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydvdread/pydvdread-1.0-r1.ebuild,v 1.2 2015/01/01 23:13:51 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
@@ -24,16 +24,6 @@ RDEPEND=""
PATCHES=( "${FILESDIR}"/${P}-py3k.patch \
"${FILESDIR}"/${P}-api-update.patch )
-src_compile() {
- # We had to patch some of the .i files, so regen the .py
- # so that the distutils copy doesn't import old stuff.
- # XXX: A python/swig expert might know a better way to do this.
- set -- swig -python -o src/dvdread/all_wrap.c src/dvdread/all.i
- echo "$@"
- "$@" || die
- distutils-r1_src_compile
-}
-
python_test() {
- "$(PYTHON)" tests/TestAll.py || die "Tests failed"
+ "${PYTHON}" tests/TestAll.py || die "Tests fail with ${EPYTHON}"
}