summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-05-04 02:22:37 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-05-04 02:22:37 +0000
commit3cb9ed6b6938fa7d32db97cca7626ed873e97ff1 (patch)
tree3d72909a0254f2c7e6b66d07f30c2355f6e08423 /dev-python
parentJust run revdep-rebuild instead of a bunch for all the possible old lib versi... (diff)
downloadgentoo-2-3cb9ed6b6938fa7d32db97cca7626ed873e97ff1.tar.gz
gentoo-2-3cb9ed6b6938fa7d32db97cca7626ed873e97ff1.tar.bz2
gentoo-2-3cb9ed6b6938fa7d32db97cca7626ed873e97ff1.zip
Version bump.
(Portage version: 2.0.51.21)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/drpython/ChangeLog8
-rw-r--r--dev-python/drpython/Manifest13
-rw-r--r--dev-python/drpython/drpython-3.10.13.ebuild30
-rw-r--r--dev-python/drpython/files/digest-drpython-3.10.131
-rw-r--r--dev-python/drpython/files/drpython.py-3.10.13.patch12
5 files changed, 53 insertions, 11 deletions
diff --git a/dev-python/drpython/ChangeLog b/dev-python/drpython/ChangeLog
index e9eb190a443b..85676b3aa341 100644
--- a/dev-python/drpython/ChangeLog
+++ b/dev-python/drpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/drpython
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.3 2005/05/02 19:52:06 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.4 2005/05/04 02:22:37 pythonhead Exp $
+
+*drpython-3.10.13 (04 May 2005)
+
+ 04 May 2005; Rob Cakebread <pythonhead@gentoo.org>
+ +files/drpython.py-3.10.13.patch, +drpython-3.10.13.ebuild:
+ Version bump.
*drpython-3.10.12 (02 May 2005)
diff --git a/dev-python/drpython/Manifest b/dev-python/drpython/Manifest
index 5da893cded8f..a7a313361ba9 100644
--- a/dev-python/drpython/Manifest
+++ b/dev-python/drpython/Manifest
@@ -1,15 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 000dfc088f871483d32945339636290b ChangeLog 924
MD5 e0398e4fe713935f5761036dde04b7dd drpython-3.10.12.ebuild 804
MD5 948a940cc7f534cf1b0b136f02d51a66 metadata.xml 381
+MD5 c6ffd64c80ea4df0cd229f16833044f3 drpython-3.10.13.ebuild 798
MD5 8f97fad63e509cc0537b92bedec9c731 files/drpython.py-3.10.12.patch 370
MD5 1ad88fcbeefa623214abdbbbc5305509 files/digest-drpython-3.10.12 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCdoUBz2gxt1z4IGYRAkyOAKDCa9bBne/v3W1DjDaI3+fGuNrXmACgp7Cz
-PUtCTPZs+Q8IhMlNIp7ilRs=
-=WRic
------END PGP SIGNATURE-----
+MD5 8f97fad63e509cc0537b92bedec9c731 files/drpython.py-3.10.13.patch 370
+MD5 d50979dcdc996758a4e570dc82d0a015 files/digest-drpython-3.10.13 65
diff --git a/dev-python/drpython/drpython-3.10.13.ebuild b/dev-python/drpython/drpython-3.10.13.ebuild
new file mode 100644
index 000000000000..95a154c8dc7b
--- /dev/null
+++ b/dev-python/drpython/drpython-3.10.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-3.10.13.ebuild,v 1.1 2005/05/04 02:22:37 pythonhead Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="A powerful cross-platform IDE for Python"
+HOMEPAGE="http://drpython.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="virtual/python
+ >=dev-python/wxpython-2.5.3.1"
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/drpython.py-${PV}.patch
+}
+
+src_install() {
+ distutils_src_install
+ distutils_python_version
+ echo -e "#!/bin/sh\n\npython /usr/lib/python${PYVER}/site-packages/drpython/drpython.py \$@" > drpython
+ dobin drpython
+}
+
diff --git a/dev-python/drpython/files/digest-drpython-3.10.13 b/dev-python/drpython/files/digest-drpython-3.10.13
new file mode 100644
index 000000000000..e60083d83257
--- /dev/null
+++ b/dev-python/drpython/files/digest-drpython-3.10.13
@@ -0,0 +1 @@
+MD5 becd6411f4334e4c01c720342ccbdbd8 drpython-3.10.13.zip 556147
diff --git a/dev-python/drpython/files/drpython.py-3.10.13.patch b/dev-python/drpython/files/drpython.py-3.10.13.patch
new file mode 100644
index 000000000000..3eda05f5104e
--- /dev/null
+++ b/dev-python/drpython/files/drpython.py-3.10.13.patch
@@ -0,0 +1,12 @@
+--- orig.drpython.py 2004-11-08 19:36:14.000000000 -0800
++++ drpython.py 2004-11-12 20:38:24.414029432 -0800
+@@ -42,6 +42,9 @@
+
+ #franz: stat is not used
+ import os.path, sys, os, shutil, re, string, traceback
++# gentoo wx selection (next two lines)
++import wxversion
++wxversion.select("2.6")
+ import wx, wx.stc
+ import drScrolledMessageDialog
+ from drNotebook import *