summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-04-30 21:29:41 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-04-30 21:29:41 +0000
commit3d1a8166f0143910b4787d0a7326d04f3c8b1665 (patch)
treef77434959095bbc6148e0eaa6909e53e41492cde /dev-python
parent- filter ssp on ia64 due to ICE in compiler. revisit when we have a working h... (diff)
downloadgentoo-2-3d1a8166f0143910b4787d0a7326d04f3c8b1665.tar.gz
gentoo-2-3d1a8166f0143910b4787d0a7326d04f3c8b1665.tar.bz2
gentoo-2-3d1a8166f0143910b4787d0a7326d04f3c8b1665.zip
Version bump.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/telepathy-python/ChangeLog8
-rw-r--r--dev-python/telepathy-python/files/digest-telepathy-python-0.13.93
-rw-r--r--dev-python/telepathy-python/telepathy-python-0.13.9.ebuild28
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/telepathy-python/ChangeLog b/dev-python/telepathy-python/ChangeLog
index 0880d89427dd..b9d4a33203db 100644
--- a/dev-python/telepathy-python/ChangeLog
+++ b/dev-python/telepathy-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/telepathy-python
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/telepathy-python/ChangeLog,v 1.4 2007/02/21 20:50:35 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/telepathy-python/ChangeLog,v 1.5 2007/04/30 21:29:40 peper Exp $
+
+*telepathy-python-0.13.9 (30 Apr 2007)
+
+ 30 Apr 2007; Piotr Jaroszyński <peper@gentoo.org>
+ +telepathy-python-0.13.9.ebuild:
+ Version bump.
*telepathy-python-0.13.8 (21 Feb 2007)
diff --git a/dev-python/telepathy-python/files/digest-telepathy-python-0.13.9 b/dev-python/telepathy-python/files/digest-telepathy-python-0.13.9
new file mode 100644
index 000000000000..d50c0c2e406f
--- /dev/null
+++ b/dev-python/telepathy-python/files/digest-telepathy-python-0.13.9
@@ -0,0 +1,3 @@
+MD5 9f265a387cbc0c25b034189e9502234b telepathy-python-0.13.9.tar.gz 65111
+RMD160 c0f2fc1b8adbdc88a17707cd3b2edff4bef57917 telepathy-python-0.13.9.tar.gz 65111
+SHA256 1fe3639f735c3074327f6a82eacf3088c03a02180a6b6f428e54ceaaace2262f telepathy-python-0.13.9.tar.gz 65111
diff --git a/dev-python/telepathy-python/telepathy-python-0.13.9.ebuild b/dev-python/telepathy-python/telepathy-python-0.13.9.ebuild
new file mode 100644
index 000000000000..a3ee8f4ed195
--- /dev/null
+++ b/dev-python/telepathy-python/telepathy-python-0.13.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/telepathy-python/telepathy-python-0.13.9.ebuild,v 1.1 2007/04/30 21:29:40 peper Exp $
+
+inherit distutils
+
+DESCRIPTION="Telepathy Python package containing base classes for use in connection managers, and proxy classes for use in clients."
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( >=dev-python/dbus-python-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if has_version "<sys-apps/dbus-0.90"; then
+ if ! built_with_use sys-apps/dbus python; then
+ eerror "You need to build dbus with USE=python."
+ die "dbus needs python bindings"
+ fi
+ fi
+}