summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-16 07:25:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-16 07:25:07 +0000
commit3db9cc5f8d3a4da1bdb93a92b2f71653c64eedb9 (patch)
treedac7c44c6031f07b0a87d2d58166a7cb73488db8 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-3db9cc5f8d3a4da1bdb93a92b2f71653c64eedb9.tar.gz
gentoo-2-3db9cc5f8d3a4da1bdb93a92b2f71653c64eedb9.tar.bz2
gentoo-2-3db9cc5f8d3a4da1bdb93a92b2f71653c64eedb9.zip
Bump for #407413
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hglib/ChangeLog7
-rw-r--r--dev-python/hglib/hglib-0.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/hglib/ChangeLog b/dev-python/hglib/ChangeLog
index df6e44aff18c..d005b708dfd4 100644
--- a/dev-python/hglib/ChangeLog
+++ b/dev-python/hglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hglib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hglib/ChangeLog,v 1.2 2012/02/22 05:40:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hglib/ChangeLog,v 1.3 2012/03/16 07:25:07 patrick Exp $
+
+*hglib-0.2 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +hglib-0.2.ebuild:
+ Bump for #407413
22 Feb 2012; Patrick Lauer <patrick@gentoo.org> hglib-0.1.ebuild:
Restricting pypy
diff --git a/dev-python/hglib/hglib-0.2.ebuild b/dev-python/hglib/hglib-0.2.ebuild
new file mode 100644
index 000000000000..459d6759ded8
--- /dev/null
+++ b/dev-python/hglib/hglib-0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hglib/hglib-0.2.ebuild,v 1.1 2012/03/16 07:25:07 patrick Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 2.6 3.* *-jython 2.7-pypy-*"
+MY_P="python-${P}"
+MY_PN="python-${PN}"
+
+inherit distutils
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/mercurial-1.9"
+DEPEND="test? ( dev-python/nose )"
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ rm tests/test-summary.py # currently fails
+ testing() {
+# local testdir="${T}/tests-${PYTHON_ABI}"
+# rm -rf "${testdir}"
+ "$(PYTHON)" test.py
+ }
+ python_execute_function testing
+}