summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-03 04:20:11 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-03 04:20:11 +0000
commit49f02389c78a9b940d510dbbce06a406e260ad95 (patch)
tree8d881edaf71f191e59fd31652c18aa59ec30c19d /dev-python
parentUse specific libsfml version dep. (diff)
downloadgentoo-2-49f02389c78a9b940d510dbbce06a406e260ad95.tar.gz
gentoo-2-49f02389c78a9b940d510dbbce06a406e260ad95.tar.bz2
gentoo-2-49f02389c78a9b940d510dbbce06a406e260ad95.zip
Migrate to distutils-r1 and use specific libsfml version dep.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysfml/ChangeLog9
-rw-r--r--dev-python/pysfml/pysfml-1.6-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/pysfml/ChangeLog b/dev-python/pysfml/ChangeLog
index f71b2ec49e22..3b685ceb98a3 100644
--- a/dev-python/pysfml/ChangeLog
+++ b/dev-python/pysfml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysfml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysfml/ChangeLog,v 1.3 2012/12/01 00:05:10 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysfml/ChangeLog,v 1.4 2014/08/03 04:20:11 radhermit Exp $
+
+*pysfml-1.6-r1 (03 Aug 2014)
+
+ 03 Aug 2014; Tim Harder <radhermit@gentoo.org> +pysfml-1.6-r1.ebuild:
+ Migrate to distutils-r1 and use specific libsfml version dep.
01 Dec 2012; Tim Harder <radhermit@gentoo.org> pysfml-1.6.ebuild:
Fix LICENSE (bug #445426 by ulm).
diff --git a/dev-python/pysfml/pysfml-1.6-r1.ebuild b/dev-python/pysfml/pysfml-1.6-r1.ebuild
new file mode 100644
index 000000000000..f4eabbabacff
--- /dev/null
+++ b/dev-python/pysfml/pysfml-1.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysfml/pysfml-1.6-r1.ebuild,v 1.1 2014/08/03 04:20:11 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for the Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="http://sfml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sfml/SFML-${PV}-python-sdk.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="~media-libs/libsfml-${PV}"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SFML-${PV}/python
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "doins failed"
+ fi
+}