summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-25 14:14:40 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-25 14:14:40 +0000
commit4aad6ca86767f7bad59e79f0e80f207ad7d23f59 (patch)
tree93bcdb57ec8cd5b9cca48c965d056f401d97cdbd /dev-python
parentVersion bump wrt bug 346739 (diff)
downloadgentoo-2-4aad6ca86767f7bad59e79f0e80f207ad7d23f59.tar.gz
gentoo-2-4aad6ca86767f7bad59e79f0e80f207ad7d23f59.tar.bz2
gentoo-2-4aad6ca86767f7bad59e79f0e80f207ad7d23f59.zip
Do not link against uneeded libs, #346751, thanks cschwan for reporting
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gdmodule/ChangeLog8
-rw-r--r--dev-python/gdmodule/files/0.56-libs.patch32
-rw-r--r--dev-python/gdmodule/gdmodule-0.56-r1.ebuild30
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/gdmodule/ChangeLog b/dev-python/gdmodule/ChangeLog
index 9f455c3a9485..3dd89e33c15d 100644
--- a/dev-python/gdmodule/ChangeLog
+++ b/dev-python/gdmodule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gdmodule
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/ChangeLog,v 1.2 2010/11/10 17:45:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/ChangeLog,v 1.3 2010/11/25 14:14:40 jlec Exp $
+
+*gdmodule-0.56-r1 (25 Nov 2010)
+
+ 25 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/0.56-libs.patch,
+ +gdmodule-0.56-r1.ebuild:
+ Do not link against uneeded libs, #346751, thanks cschwan for reporting
10 Nov 2010; Fabian Groffen <grobian@gentoo.org> gdmodule-0.56.ebuild:
Marked ~x86-linux, ~ppc-macos, bug #341991
diff --git a/dev-python/gdmodule/files/0.56-libs.patch b/dev-python/gdmodule/files/0.56-libs.patch
new file mode 100644
index 000000000000..aac6405b3332
--- /dev/null
+++ b/dev-python/gdmodule/files/0.56-libs.patch
@@ -0,0 +1,32 @@
+diff --git a/Setup.py b/Setup.py
+index c6ef27f..8baedc4 100644
+--- a/Setup.py
++++ b/Setup.py
+@@ -40,7 +40,7 @@ def remove(itm, lst):
+ # Unixoid OS's I will just look for the usual suspects.
+
+ libdirs = dirtest([
+- "/usr/local/lib", "/sw/lib", "/usr/lib",
++ "/usr/lib", "/usr/lib64",
+ "/usr/lib/X11", "/usr/X11R6/lib",
+ "/opt/gnome/lib",
+ ])
+@@ -48,7 +48,7 @@ libdirs = dirtest([
+ # include_dirs are also non-portable; same trick here.
+
+ incdirs = dirtest([
+- "/usr/local/include", "/sw/include", "/usr/include",
++ "/usr/include",
+ "/usr/include/X11", "/usr/X11R6/include",
+ "/opt/gnome/include",
+ ])
+@@ -57,9 +57,6 @@ incdirs = dirtest([
+
+ want_libs = [
+ "gd",
+- "jpeg", "png", "gif", "z",
+- "X11", "Xpm",
+- "ttf", "freetype",
+ ]
+
+ libs = filetest(libdirs, want_libs)
diff --git a/dev-python/gdmodule/gdmodule-0.56-r1.ebuild b/dev-python/gdmodule/gdmodule-0.56-r1.ebuild
new file mode 100644
index 000000000000..30524bff7e41
--- /dev/null
+++ b/dev-python/gdmodule/gdmodule-0.56-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/gdmodule-0.56-r1.ebuild,v 1.1 2010/11/25 14:14:40 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Python extensions for gd"
+HOMEPAGE="http://newcenturycomputers.net/projects/gdmodule.html"
+SRC_URI="http://newcenturycomputers.net/projects/download.cgi/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="media-libs/gd"
+DEPEND="${RDEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-libs.patch
+ mv Setup.py setup.py
+ distutils_src_prepare
+}