summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-07 02:59:28 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-07 02:59:28 +0000
commit4edb24a27d8cb150c036a796b7f1b81a45fea733 (patch)
tree4b2d36f904a2bd86ed9ed6da521c3a96b1dd8d57 /dev-python
parentrevbump; conversion -> distutils-r1 (diff)
downloadgentoo-2-4edb24a27d8cb150c036a796b7f1b81a45fea733.tar.gz
gentoo-2-4edb24a27d8cb150c036a796b7f1b81a45fea733.tar.bz2
gentoo-2-4edb24a27d8cb150c036a796b7f1b81a45fea733.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ropeide/ChangeLog11
-rw-r--r--dev-python/ropeide/ropeide-1.5.1-r2.ebuild (renamed from dev-python/ropeide/ropeide-1.5.1-r1.ebuild)21
2 files changed, 17 insertions, 15 deletions
diff --git a/dev-python/ropeide/ChangeLog b/dev-python/ropeide/ChangeLog
index 16b799814969..c71be28ba287 100644
--- a/dev-python/ropeide/ChangeLog
+++ b/dev-python/ropeide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ropeide
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ChangeLog,v 1.5 2012/02/22 05:45:24 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ChangeLog,v 1.6 2015/01/07 02:59:28 idella4 Exp $
+
+*ropeide-1.5.1-r2 (07 Jan 2015)
+
+ 07 Jan 2015; Ian Delaney <idella4@gentoo.org> +ropeide-1.5.1-r2.ebuild,
+ -ropeide-1.5.1-r1.ebuild:
+ revbump; conversion -> distutils-r1, rm old
22 Feb 2012; Patrick Lauer <patrick@gentoo.org> ropeide-1.5.1-r1.ebuild:
Restricting pypy and jython
@@ -24,4 +30,3 @@
+ropeide-1.5.1.ebuild:
Initial commit. Bug #202700. Thanks Matsui Tetsushi <VED03370@nifty.ne.jp>
for the ebuild.
-
diff --git a/dev-python/ropeide/ropeide-1.5.1-r1.ebuild b/dev-python/ropeide/ropeide-1.5.1-r2.ebuild
index 723a05f2139c..3bdca4aa533e 100644
--- a/dev-python/ropeide/ropeide-1.5.1-r1.ebuild
+++ b/dev-python/ropeide/ropeide-1.5.1-r2.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ropeide-1.5.1-r1.ebuild,v 1.4 2012/02/22 05:45:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ropeide-1.5.1-r2.ebuild,v 1.1 2015/01/07 02:59:28 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* 2.7-pypy-* *-jython"
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
-inherit distutils
+inherit distutils-r1
+PYTHON_REQ_USE="tk"
DESCRIPTION="Python refactoring IDE"
HOMEPAGE="http://rope.sourceforge.net/ropeide.html http://pypi.python.org/pypi/ropeide"
@@ -19,13 +17,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND=">=dev-python/rope-0.8.4"
+DEPEND=">=dev-python/rope-0.8.4[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
-src_install() {
- distutils_src_install
-
+python_install_all() {
if use doc; then
dodoc docs/*.txt || die "dodoc failed"
fi
+ distutils-r1_python_install_all
}