summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-07 18:21:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-07 18:21:23 +0000
commit57c57ae6410254fc2c724c0fab05d05d6296672d (patch)
tree85599a5b299a6a9f9bc7ac94e2795cce277bd217 /dev-python
parentVersion bump, cleaning old versions. (diff)
downloadgentoo-2-57c57ae6410254fc2c724c0fab05d05d6296672d.tar.gz
gentoo-2-57c57ae6410254fc2c724c0fab05d05d6296672d.tar.bz2
gentoo-2-57c57ae6410254fc2c724c0fab05d05d6296672d.zip
Version bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyqwt/ChangeLog10
-rw-r--r--dev-python/pyqwt/metadata.xml7
-rw-r--r--dev-python/pyqwt/pyqwt-5.0.1.ebuild67
-rw-r--r--dev-python/pyqwt/pyqwt-5.1.0.ebuild49
4 files changed, 64 insertions, 69 deletions
diff --git a/dev-python/pyqwt/ChangeLog b/dev-python/pyqwt/ChangeLog
index d31b523f1fdc..ba459312e18d 100644
--- a/dev-python/pyqwt/ChangeLog
+++ b/dev-python/pyqwt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyqwt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.11 2008/10/27 10:50:09 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.12 2009/04/07 18:21:23 bicatali Exp $
+
+*pyqwt-5.1.0 (07 Apr 2009)
+
+ 07 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ -pyqwt-5.0.1.ebuild, +pyqwt-5.1.0.ebuild:
+ Version bump
27 Oct 2008; Ali Polatel <hawking@gentoo.org> pyqwt-4.2-r1.ebuild,
pyqwt-5.0.1.ebuild:
diff --git a/dev-python/pyqwt/metadata.xml b/dev-python/pyqwt/metadata.xml
index a789e7bbe9ee..4c7b8a7ec906 100644
--- a/dev-python/pyqwt/metadata.xml
+++ b/dev-python/pyqwt/metadata.xml
@@ -3,4 +3,11 @@
<pkgmetadata>
<herd>python</herd>
<herd>qt</herd>
+<longdescription lang="en">
+ PyQwt is a set of Python bindings for the Qwt C++ class library which
+ extends the Qt framework with widgets for scientific and engineering
+ applications. It provides a widget to plot 2-dimensional data and
+ various widgets to display and control bounded or unbounded floating
+ point values.
+</longdescription>
</pkgmetadata>
diff --git a/dev-python/pyqwt/pyqwt-5.0.1.ebuild b/dev-python/pyqwt/pyqwt-5.0.1.ebuild
deleted file mode 100644
index 363322aeae88..000000000000
--- a/dev-python/pyqwt/pyqwt-5.0.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.0.1.ebuild,v 1.6 2008/10/27 10:50:09 hawking Exp $
-
-EAPI="1"
-inherit eutils python toolchain-funcs
-
-MY_P="PyQwt-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Python bindings for the Qwt library"
-SRC_URI="mirror://sourceforge/pyqwt/${MY_P}.tar.gz"
-HOMEPAGE="http://pyqwt.sourceforge.net/"
-SLOT="5"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="debug doc examples"
-
-RDEPEND="virtual/python
- x11-libs/qwt:5
- >=dev-python/PyQt4-4.2
- >=dev-python/numpy-1.0.1"
-DEPEND="${DEPEND}
- >=dev-python/sip-4.1.1"
-
-src_unpack() {
- unpack ${A}
-
- # PyQwt CVS does not need the next 2 sed statements anymore
- sed -i \
- -e "s|%Import QtSvg/QtSvgmod.sip||" \
- -e "s|%Include qwt_plot_svgitem.sip||" \
- "${S}/sip/qwt5qt4/QwtModule.sip" || die "sed failed"
-
- # Avoid pre-stripped files
- sed -i \
- -e 's|ModuleMakefile(|ModuleMakefile(strip=0,|' \
- "${S}/configure/configure.py" || die "sed failed"
-}
-
-src_compile() {
- cd "${S}/configure"
-
- local myconf="-I/usr/include/qwt5 -lqwt --disable-numarray --disable-numeric"
- use debug && myconf="${myconf} --debug"
- has distcc ${FEATURES} || myconf="${myconf} -j1"
-
- python_version
- "${python}" configure.py ${myconf} || die "python configure.py failed"
- emake CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- cd "${S}/configure"
- emake DESTDIR="${D}" install || die "make install failed"
-
- cd "${S}"
- dodoc ANNOUNCEMENT-${PV} CHANGES-${PV} COPYING* README
-
- use doc && dohtml Doc/html/pyqwt/*
-
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r qt4examples/ "${D}/usr/share/doc/${PF}/examples"
- fi
-}
diff --git a/dev-python/pyqwt/pyqwt-5.1.0.ebuild b/dev-python/pyqwt/pyqwt-5.1.0.ebuild
new file mode 100644
index 000000000000..e6cff6b3b74d
--- /dev/null
+++ b/dev-python/pyqwt/pyqwt-5.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.1.0.ebuild,v 1.1 2009/04/07 18:21:23 bicatali Exp $
+
+EAPI=2
+inherit eutils python toolchain-funcs
+
+MY_P="PyQwt-${PV}"
+S="${WORKDIR}/${MY_P}/configure"
+
+DESCRIPTION="Python bindings for the Qwt library"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://pyqwt.sourceforge.net/"
+SLOT="5"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="debug doc examples svg"
+
+RDEPEND="=x11-libs/qwt-5.1*[svg?]
+ >=dev-python/PyQt4-4.2
+ dev-python/numpy"
+DEPEND="${DEPEND}
+ >=dev-python/sip-4.6"
+
+src_configure() {
+ # the -j option can be buggy
+ python_version
+ "${python}" configure.py \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt \
+ || die "python configure.py failed"
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd ..
+ dodoc ANNOUNCEMENT-${PV} CHANGES-${PV} README
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r Doc/html || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins qt4examples/* || die
+ fi
+}