summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-14 02:44:35 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-14 02:44:35 +0000
commit5e08964d83a05c9fa2e49f113e9a8df8c39e35cb (patch)
tree6b53caee215caf4acf3ad110ab31f0932dfe6826 /dev-python
parentStable for HPPA (bug #300865). (diff)
downloadgentoo-2-5e08964d83a05c9fa2e49f113e9a8df8c39e35cb.tar.gz
gentoo-2-5e08964d83a05c9fa2e49f113e9a8df8c39e35cb.tar.bz2
gentoo-2-5e08964d83a05c9fa2e49f113e9a8df8c39e35cb.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-poppler/ChangeLog10
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/python-poppler/ChangeLog b/dev-python/python-poppler/ChangeLog
index bc180bf307b2..4aded9b25889 100644
--- a/dev-python/python-poppler/ChangeLog
+++ b/dev-python/python-poppler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-poppler
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.3 2009/09/03 19:26:55 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.4 2010/01/14 02:44:35 yngwin Exp $
+
+*python-poppler-0.12.1 (14 Jan 2010)
+
+ 14 Jan 2010; Ben de Groot <yngwin@gentoo.org>
+ +python-poppler-0.12.1.ebuild:
+ Version bump
03 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-poppler-0.10.1.ebuild:
diff --git a/dev-python/python-poppler/python-poppler-0.12.1.ebuild b/dev-python/python-poppler/python-poppler-0.12.1.ebuild
new file mode 100644
index 000000000000..be03436de113
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.12.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1.ebuild,v 1.1 2010/01/14 02:44:35 yngwin Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.6"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit libtool python
+
+DESCRIPTION="Python bindings to the Poppler PDF library."
+SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/poppler-python"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/pypoppler-${PV}"
+
+RDEPEND=">=virtual/poppler-glib-0.12.0
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ >=dev-python/pycairo-1.8.4"
+DEPEND="${RDEPEND}"
+
+RESTRICT_PYTHON_ABIS="2.4 2.5 3*"
+
+src_prepare() {
+ elibtoolize
+ python_copy_sources
+}
+
+src_install() {
+ python_src_install
+ find "${D}" -name '*.la' -type f -exec rm -f '{}' ';' || die "Removing .la files failed"
+ dodoc NEWS
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/demo-poppler.py
+ fi
+}