summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-22 08:21:49 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-22 08:21:49 +0000
commit72f9ef758f4f8b9455241248e9728969d442044f (patch)
treeba855fef395e4ed590d9cd511052d013687ef322 /dev-python
parentnet-analyzer/openvas-cli: Fix S (diff)
downloadgentoo-2-72f9ef758f4f8b9455241248e9728969d442044f.tar.gz
gentoo-2-72f9ef758f4f8b9455241248e9728969d442044f.tar.bz2
gentoo-2-72f9ef758f4f8b9455241248e9728969d442044f.zip
re-add 1.1.21 to appease old rev deps with SLOT 0, rm more old
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/psycopg/ChangeLog8
-rw-r--r--dev-python/psycopg/psycopg-1.1.21.ebuild56
-rw-r--r--dev-python/psycopg/psycopg-2.4.1.ebuild78
-rw-r--r--dev-python/psycopg/psycopg-2.4.2.ebuild79
-rw-r--r--dev-python/psycopg/psycopg-2.4.4.ebuild78
5 files changed, 63 insertions, 236 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index 330570082224..a4d34a75f458 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.179 2014/10/21 12:07:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.180 2014/10/22 08:21:49 idella4 Exp $
+
+*psycopg-1.1.21 (22 Oct 2014)
+
+ 22 Oct 2014; Ian Delaney <idella4@gentoo.org> +psycopg-1.1.21.ebuild,
+ -psycopg-2.4.1.ebuild, -psycopg-2.4.2.ebuild, -psycopg-2.4.4.ebuild:
+ re-add 1.1.21 to appease old rev deps with SLOT 0, rm more old
21 Oct 2014; Jeroen Roovers <jer@gentoo.org> psycopg-2.5.3.ebuild:
Stable for HPPA (bug #525508).
diff --git a/dev-python/psycopg/psycopg-1.1.21.ebuild b/dev-python/psycopg/psycopg-1.1.21.ebuild
new file mode 100644
index 000000000000..420ea0dba2ab
--- /dev/null
+++ b/dev-python/psycopg/psycopg-1.1.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21.ebuild,v 1.23 2014/10/22 08:21:49 idella4 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit python
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://www.initd.org/software/psycopg"
+SRC_URI="http://initd.org/pub/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=dev-python/egenix-mx-base-2.0.3
+ dev-db/postgresql-base"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix for bug #134873
+ sed -e '1245s/static //' -i cursor.c
+
+ sed -e 's:$(PY_MOD_DIR):$(D)&/$$mod:' -i Makefile.pre.in
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ econf \
+ --with-mxdatetime-includes="$(python_get_includedir)/mx" \
+ --with-postgres-includes="/usr/include/postgresql/server" || return 1
+ sed -e 's:$(BLDSHARED):& $(LDFLAGS):' -i Makefile
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_src_compile OPT="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ python_src_install
+
+ dodoc AUTHORS ChangeLog CREDITS README NEWS RELEASE-1.0 SUCCESS TODO
+ docinto doc
+ dodoc doc/python-taylor.txt doc/README
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*
+}
diff --git a/dev-python/psycopg/psycopg-2.4.1.ebuild b/dev-python/psycopg/psycopg-2.4.1.ebuild
deleted file mode 100644
index 171d3c56f7e7..000000000000
--- a/dev-python/psycopg/psycopg-2.4.1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.1.ebuild,v 1.9 2012/09/30 16:54:18 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-* *-jython"
-
-inherit distutils eutils
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 ~arm ~hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="debug doc examples mxdatetime"
-
-RDEPEND=">=dev-db/postgresql-base-8.1
- mxdatetime? ( dev-python/egenix-mx-base )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="AUTHORS doc/HACKING doc/SUCCESS"
-PYTHON_MODNAME="${PN}2"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.0.12-setup.py.patch"
- epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
-
- python_convert_shebangs 2 doc/src/tools/stitch_text.py
-
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
- fi
-
- if use mxdatetime; then
- sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
- fi
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd doc > /dev/null
- emake -j1 html text || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dodoc doc/psycopg2.txt || die "dodoc failed"
-
- pushd doc/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/psycopg/psycopg-2.4.2.ebuild b/dev-python/psycopg/psycopg-2.4.2.ebuild
deleted file mode 100644
index e27f1d9a9144..000000000000
--- a/dev-python/psycopg/psycopg-2.4.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.2.ebuild,v 1.9 2012/09/30 16:54:18 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-* *-jython"
-
-inherit distutils eutils
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 ~arm ~hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="debug doc examples mxdatetime"
-
-RDEPEND=">=dev-db/postgresql-base-8.1
- mxdatetime? ( dev-python/egenix-mx-base )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="AUTHORS doc/HACKING doc/SUCCESS"
-PYTHON_MODNAME="${PN}2"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-setup.py.patch"
- epatch "${FILESDIR}/${P}-begin-segfault.patch"
- epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
-
- python_convert_shebangs 2 doc/src/tools/stitch_text.py
-
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
- fi
-
- if use mxdatetime; then
- sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
- fi
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd doc > /dev/null
- emake -j1 html text || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dodoc doc/psycopg2.txt || die "dodoc failed"
-
- pushd doc/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/psycopg/psycopg-2.4.4.ebuild b/dev-python/psycopg/psycopg-2.4.4.ebuild
deleted file mode 100644
index 05ba17d26285..000000000000
--- a/dev-python/psycopg/psycopg-2.4.4.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.4.ebuild,v 1.4 2012/09/30 16:54:18 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-* *-jython"
-
-inherit distutils eutils
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="debug doc examples mxdatetime"
-
-RDEPEND=">=dev-db/postgresql-base-8.1
- mxdatetime? ( dev-python/egenix-mx-base )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="AUTHORS doc/HACKING doc/SUCCESS"
-PYTHON_MODNAME="${PN}2"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.4.2-setup.py.patch"
- epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
-
- python_convert_shebangs 2 doc/src/tools/stitch_text.py
-
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
- fi
-
- if use mxdatetime; then
- sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
- fi
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd doc > /dev/null
- emake -j1 html text || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dodoc doc/psycopg2.txt || die "dodoc failed"
-
- pushd doc/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}