summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-07 07:29:44 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-07 07:29:44 +0000
commit7ec5c0c85dceac725679e5dbe7f6ddc1b4569c53 (patch)
treee4c6f416294f9b111def6c2a790d999fccf77574 /dev-python
parentbump, rm old (diff)
downloadgentoo-2-7ec5c0c85dceac725679e5dbe7f6ddc1b4569c53.tar.gz
gentoo-2-7ec5c0c85dceac725679e5dbe7f6ddc1b4569c53.tar.bz2
gentoo-2-7ec5c0c85dceac725679e5dbe7f6ddc1b4569c53.zip
bump, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/geopy/ChangeLog8
-rw-r--r--dev-python/geopy/geopy-1.8.1.ebuild (renamed from dev-python/geopy/geopy-1.6.1.ebuild)16
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-python/geopy/ChangeLog b/dev-python/geopy/ChangeLog
index 4e3ee1d227e6..f58684e39fdf 100644
--- a/dev-python/geopy/ChangeLog
+++ b/dev-python/geopy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/geopy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/ChangeLog,v 1.20 2015/01/12 03:21:29 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/ChangeLog,v 1.21 2015/02/07 07:29:44 idella4 Exp $
+
+*geopy-1.8.1 (07 Feb 2015)
+
+ 07 Feb 2015; Ian Delaney <idella4@gentoo.org> +geopy-1.8.1.ebuild,
+ -geopy-1.6.1.ebuild:
+ bump, rm old
*geopy-1.7.1 (12 Jan 2015)
diff --git a/dev-python/geopy/geopy-1.6.1.ebuild b/dev-python/geopy/geopy-1.8.1.ebuild
index 10bbbc656e32..1d50420dbf7b 100644
--- a/dev-python/geopy/geopy-1.6.1.ebuild
+++ b/dev-python/geopy/geopy-1.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-1.6.1.ebuild,v 1.1 2014/12/24 10:32:18 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-1.8.1.ebuild,v 1.1 2015/02/07 07:29:44 idella4 Exp $
EAPI=5
@@ -24,7 +24,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}]
dev-python/nose-cover3[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}] )
- doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
+ doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
>=dev-python/python-docs-2.7.6-r1:2.7 )"
python_prepare_all() {
@@ -38,14 +38,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
- # purge test folder to avoid file collisions
+ # prevent install of test folder to avoid file collisions
sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
}
python_test() {
- # intermittent fails or errors caused by an apparent race condition. suite is fine
- # test test_geocode attempts to connect the network and is excluded here
- nosetests -e test_geocode || die "Tests failed under ${EPYTHON}"
+ # Ignore rogue class IGNFranceTestCase demanding elements beyond a normal testsuite
+ # i.e. "You should provide an api key and a username with a password"
+ # Cannot decipher how to skip or exclude this "context=IGNFranceTestCase"
+ # It appears it MAY stem from nose rather than geopy's suite
+ nosetests --verbose || die "Tests failed under ${EPYTHON}"
}
python_compile_all() {