summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-26 10:33:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-26 10:33:33 +0000
commit80a829be6fa7bb05df138870e056fc561bab9115 (patch)
treea7a30405c4d6debdc869b23c385bd5a9dd243477 /dev-python
parentstable x86, bug 291783 (diff)
downloadgentoo-2-80a829be6fa7bb05df138870e056fc561bab9115.tar.gz
gentoo-2-80a829be6fa7bb05df138870e056fc561bab9115.tar.bz2
gentoo-2-80a829be6fa7bb05df138870e056fc561bab9115.zip
Bump
(Portage version: 2.2_rc52/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snakeoil/ChangeLog7
-rw-r--r--dev-python/snakeoil/snakeoil-0.3.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/snakeoil/ChangeLog b/dev-python/snakeoil/ChangeLog
index 8fbd3e663e43..f26dd6fd00e8 100644
--- a/dev-python/snakeoil/ChangeLog
+++ b/dev-python/snakeoil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/snakeoil
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.22 2009/09/04 16:02:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.23 2009/11/26 10:33:33 patrick Exp $
+
+*snakeoil-0.3.3 (26 Nov 2009)
+
+ 26 Nov 2009; Patrick Lauer <patrick@gentoo.org> +snakeoil-0.3.3.ebuild:
+ Bump
04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -snakeoil-0.3.ebuild,
-snakeoil-0.3.1.ebuild:
diff --git a/dev-python/snakeoil/snakeoil-0.3.3.ebuild b/dev-python/snakeoil/snakeoil-0.3.3.ebuild
new file mode 100644
index 000000000000..562a74104dc5
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.3.3.ebuild,v 1.1 2009/11/26 10:33:33 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Miscellaneous python utility code."
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DOCS="AUTHORS NEWS"
+DEPEND="!<sys-apps/pkgcore-0.4.7.8"
+RDEPEND=${DEPEND}
+
+# Uses an ugly hack to install for all versions of python on the
+# system. This should be supported through the eclass at some point.
+# pkgcore needs it now to support upgrading to a different python slot.
+
+src_compile() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_compile
+ done
+ python=${opython}
+}
+
+src_test() {
+ local opython=${python} tempdir
+ for python in /usr/bin/python2.[4-9]; do
+ tempdir="${T}/tests/$(basename ${python})"
+ mkdir -p "${tempdir}" || die "tempdir creation failed"
+ cp -r "${S}" "${tempdir}" || die "test copy failed"
+ cd "${tempdir}/${P}"
+ "${python}" setup.py test || die "testing returned non zero"
+ done
+ python=${opython}
+ rm -rf "${T}/tests"
+}
+
+src_install() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_install
+ done
+}