summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Balistreri <brain@gentoo.org>2003-04-12 14:12:14 +0000
committerMichele Balistreri <brain@gentoo.org>2003-04-12 14:12:14 +0000
commit8cde752153eb267120d59a1e4e2222e7677264d7 (patch)
treeea86eed7e6f8a00266857f4b2c0c35c6e17ca2e0 /dev-python
parentslocate (diff)
downloadgentoo-2-8cde752153eb267120d59a1e4e2222e7677264d7.tar.gz
gentoo-2-8cde752153eb267120d59a1e4e2222e7677264d7.tar.bz2
gentoo-2-8cde752153eb267120d59a1e4e2222e7677264d7.zip
Fix bug #19008
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog7
-rw-r--r--dev-python/PyQt/PyQt-3.5-r1.ebuild16
-rw-r--r--dev-python/PyQt/files/license-3.5.diff34
-rw-r--r--dev-python/PyQt/files/qt3.1.2-compilation-fix-3.5.diff77
4 files changed, 91 insertions, 43 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index e1f4583fc9d8..c49094b0adfe 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.12 2003/02/26 18:33:36 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.13 2003/04/12 14:12:13 brain Exp $
+ 12 Apr 2003; Michele Balistreri <brain@gentoo.org> ChangeLog :
+
+ Fix compilation bug with QT 3.1.2 (bug #19008)
+
+
26 Feb 2003; Dan Armak <danarmak@gentoo.org> ChangeLog :
Fix possible sandbox error as per bug #12393.
diff --git a/dev-python/PyQt/PyQt-3.5-r1.ebuild b/dev-python/PyQt/PyQt-3.5-r1.ebuild
index c1abdbe6f767..1a2c9db1f38d 100644
--- a/dev-python/PyQt/PyQt-3.5-r1.ebuild
+++ b/dev-python/PyQt/PyQt-3.5-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5-r1.ebuild,v 1.3 2003/02/28 16:54:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5-r1.ebuild,v 1.4 2003/04/12 14:12:13 brain Exp $
+
+inherit eutils
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
@@ -14,15 +16,13 @@ KEYWORDS="~x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc
sys-devel/libtool
>=x11-libs/qt-3.0.4.1
- >=dev-lang/python-2.2.1
- =dev-python/sip-${PV}"
+ >=dev-lang/python-2.2.1
+ =dev-python/sip-${PV}"
src_unpack() {
-
- unpack PyQt-x11-gpl-${PV}.tar.gz
- cd ${S}
- patch -p0 < ${FILESDIR}/license-3.5.diff
-
+ unpack PyQt-x11-gpl-${PV}.tar.gz
+ cd ${S}
+ epatch $FILESDIR/qt3.1.2-compilation-fix-3.5.diff
}
diff --git a/dev-python/PyQt/files/license-3.5.diff b/dev-python/PyQt/files/license-3.5.diff
deleted file mode 100644
index 82d3106b7212..000000000000
--- a/dev-python/PyQt/files/license-3.5.diff
+++ /dev/null
@@ -1,34 +0,0 @@
---- build.py.orig 2002-12-13 23:43:10.000000000 +0100
-+++ build.py 2002-12-13 23:43:23.000000000 +0100
-@@ -646,31 +646,6 @@
- licType = "GPL"
- licname = "GNU General Public License"
-
-- inform("This is the %s version of PyQt and is licensed under the %s." % (licType,licname),0)
--
-- print
-- print "Type 'L' to view the license."
-- print "Type 'yes' to accept the terms of the license."
-- print "Type 'no' to decline the terms of the license."
-- print
--
-- while 1:
-- try:
-- resp = raw_input("Do you accept the terms of the license? ")
-- except:
-- resp = ""
--
-- resp = resp.strip().lower()
--
-- if resp == "yes":
-- break
--
-- if resp == "no":
-- sys.exit(0)
--
-- if resp == "l":
-- os.system("more LICENSE")
--
- inform("Building the %s version of PyQt 3.5 for Python %s on %s." % (licType,pyFullVers,sys.platform))
-
- if licType != "GPL":
diff --git a/dev-python/PyQt/files/qt3.1.2-compilation-fix-3.5.diff b/dev-python/PyQt/files/qt3.1.2-compilation-fix-3.5.diff
new file mode 100644
index 000000000000..03eff43eb5f1
--- /dev/null
+++ b/dev-python/PyQt/files/qt3.1.2-compilation-fix-3.5.diff
@@ -0,0 +1,77 @@
+--- build.py.orig 2003-04-11 23:47:44.000000000 +0200
++++ build.py 2003-04-11 23:50:31.000000000 +0200
+@@ -646,31 +646,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of PyQt and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = resp.strip().lower()
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ inform("Building the %s version of PyQt 3.5 for Python %s on %s." % (licType,pyFullVers,sys.platform))
+
+ if licType != "GPL":
+@@ -1382,7 +1357,8 @@
+ 0x030006: "Qt_3_0_5",
+ 0x030100: "Qt_3_0_6",
+ 0x030101: "Qt_3_1_0",
+- 0x040000: "Qt_3_1_1"
++ 0x030102: "Qt_3_1_1",
++ 0x040000: "Qt_3_1_2"
+ }
+
+ global qtVersion
+--- sip/qdatetimeedit.sip.orig 2003-04-11 16:46:14.000000000 +0200
++++ sip/qdatetimeedit.sip 2003-04-11 17:20:03.000000000 +0200
+@@ -1,7 +1,7 @@
+ // This is the SIP interface definition for QDateEdit, QDateTimeEdit and
+ // QTimeEdit.
+ //
+-// Copyright (c) 2002
++// Copyright (c) 2003
+ // Riverbank Computing Limited <info@riverbankcomputing.co.uk>
+ //
+ // This file is part of PyQt.
+@@ -231,7 +231,9 @@
+ protected:
+ void init();
+ void resizeEvent(QResizeEvent *);
+- void layoutEditors();
++%If (- Qt_3_1_2)
++ void layoutEditors();
++%End
+
+ protected slots:
+ void newValue(const QDate &);
+--- sip/versions.sip.orig 2003-04-11 16:46:29.000000000 +0200
++++ sip/versions.sip 2003-04-11 16:46:41.000000000 +0200
+@@ -26,7 +26,7 @@
+ %Timeline {Qt_1_43
+ Qt_2_00 Qt_2_1_0 Qt_2_2_0 Qt_2_3_0 Qt_2_3_1
+ Qt_3_0_0 Qt_3_0_1 Qt_3_0_2 Qt_3_0_4 Qt_3_0_5 Qt_3_0_6
+- Qt_3_1_0 Qt_3_1_1}
++ Qt_3_1_0 Qt_3_1_1 Qt_3_1_2}
+
+
+ // Specify the platforms.