summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-25 19:41:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-25 19:41:28 +0000
commit91a8cef68a939721e658efd7adb8ea7bafedf0db (patch)
tree01abe3cd7809031ddf06f282c98d6ed044c17dc5 /dev-python
parentBump (diff)
downloadgentoo-2-91a8cef68a939721e658efd7adb8ea7bafedf0db.tar.gz
gentoo-2-91a8cef68a939721e658efd7adb8ea7bafedf0db.tar.bz2
gentoo-2-91a8cef68a939721e658efd7adb8ea7bafedf0db.zip
Version bump.
(Portage version: 2.2_rc86_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/subvertpy/ChangeLog8
-rw-r--r--dev-python/subvertpy/subvertpy-0.7.4.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index 3cd60a25519f..7007f63bcc8a 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.20 2010/09/17 14:29:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.21 2010/09/25 19:41:28 arfrever Exp $
+
+*subvertpy-0.7.4 (25 Sep 2010)
+
+ 25 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +subvertpy-0.7.4.ebuild:
+ Version bump.
17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-subvertpy-0.7.2.ebuild, -subvertpy-0.7.3.ebuild:
diff --git a/dev-python/subvertpy/subvertpy-0.7.4.ebuild b/dev-python/subvertpy/subvertpy-0.7.4.ebuild
new file mode 100644
index 000000000000..be73f5daf5be
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.7.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.4.ebuild,v 1.1 2010/09/25 19:41:28 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-vcs/subversion-1.4"
+RDEPEND="${DEPEND}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="NEWS AUTHORS"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/subvertpy/tests"
+ }
+ python_execute_function -q delete_tests
+}