summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-11-30 00:04:59 +0000
committerMarien Zwart <marienz@gentoo.org>2006-11-30 00:04:59 +0000
commit91eef59ef310014766b9c9259c8e0e8e4f5018ff (patch)
treec865ec97380874b7ef9cf7da53a6da548b4e6258 /dev-python
parentVersion bump (see bug #156425). (diff)
downloadgentoo-2-91eef59ef310014766b9c9259c8e0e8e4f5018ff.tar.gz
gentoo-2-91eef59ef310014766b9c9259c8e0e8e4f5018ff.tar.bz2
gentoo-2-91eef59ef310014766b9c9259c8e0e8e4f5018ff.zip
Version bump, remove old versions. Close bug #156624, thanks to Daniel Drake <dsd@gentoo.org> for reporting.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog11
-rw-r--r--dev-python/pylint/files/digest-pylint-0.12.23
-rw-r--r--dev-python/pylint/pylint-0.12.2.ebuild61
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 2ad271a09441..e1b13ab12b60 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/pylint
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.30 2006/09/27 00:08:04 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.31 2006/11/30 00:04:59 marienz Exp $
+
+*pylint-0.12.2 (30 Nov 2006)
+
+ 30 Nov 2006; Marien Zwart <marienz@gentoo.org>
+ -files/pylint-0.9.0-extra-todo.patch, -pylint-0.4.0.ebuild,
+ -pylint-0.7.0.ebuild, -pylint-0.8.1.ebuild, -pylint-0.9.0.ebuild,
+ -pylint-0.10.0.ebuild, +pylint-0.12.2.ebuild:
+ Version bump, remove old versions. Close bug #156624, thanks to Daniel Drake
+ <dsd@gentoo.org> for reporting.
*pylint-0.12.1 (27 Sep 2006)
diff --git a/dev-python/pylint/files/digest-pylint-0.12.2 b/dev-python/pylint/files/digest-pylint-0.12.2
new file mode 100644
index 000000000000..57d2de3ace90
--- /dev/null
+++ b/dev-python/pylint/files/digest-pylint-0.12.2
@@ -0,0 +1,3 @@
+MD5 38333614235969f9e715c71666cc596f pylint-0.12.2.tar.gz 160117
+RMD160 92c88488d1c197833e5ea831674beb42b38262ea pylint-0.12.2.tar.gz 160117
+SHA256 828179fbe07c0611fd6ce30fc37cada28291f3f5b9d4729d7495d02d073eabf4 pylint-0.12.2.tar.gz 160117
diff --git a/dev-python/pylint/pylint-0.12.2.ebuild b/dev-python/pylint/pylint-0.12.2.ebuild
new file mode 100644
index 000000000000..bce93ac1fe8d
--- /dev/null
+++ b/dev-python/pylint/pylint-0.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.12.2.ebuild,v 1.1 2006/11/30 00:04:59 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding standard"
+SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
+ >=dev-python/logilab-common-0.13.0
+ >=dev-python/astng-0.16.0"
+
+DOCS="doc/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make the test that tries to import gtk a bit less strict
+ epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
+
+ # Make pylint-gui print a gentoo-specific message if Tkinter is missing
+ epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
+}
+
+src_install() {
+ distutils_src_install
+ # do not install the test suite (we ran it from src_test already
+ # and it makes .py[co] generation very noisy because there are
+ # files with SyntaxErrors in there)
+ python_version
+ rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
+
+ doman man/pylint.1
+ dohtml doc/*.html
+}
+
+src_test() {
+ # The tests will not work properly from the source dir, so do a
+ # temporary install:
+ "${python}" setup.py install --home="${T}/test" || die "test copy failed"
+ # dir needs to be this or the tests fail
+ cd "${T}/test/lib/python/pylint/test"
+ PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
+ die "tests failed"
+ cd "${S}"
+ rm -rf "${T}/test"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ einfo 'A couple of important configuration settings (like "disable-msg")'
+ einfo 'moved from the "MASTER" to "MESSAGES CONTROL" section.'
+ einfo 'See "pylint --help".'
+}