summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-27 14:25:26 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-27 14:25:26 +0000
commit95680d4d397e6d19680180d5601d7266023c0232 (patch)
treedb9babdb8a5ba095ed4f6927525ef89bc24d0b6e /dev-python
parentDon't append -O3, bug #454304 by Agostino Sarubbo (diff)
downloadgentoo-2-95680d4d397e6d19680180d5601d7266023c0232.tar.gz
gentoo-2-95680d4d397e6d19680180d5601d7266023c0232.tar.bz2
gentoo-2-95680d4d397e6d19680180d5601d7266023c0232.zip
revbump; migrated to distutils-r1, un-needed eutils dropped, fix to building of docs, fixes Bug #453758, thx to flameeyes
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyx/ChangeLog11
-rw-r--r--dev-python/pyx/pyx-0.12.1-r1.ebuild46
-rw-r--r--dev-python/pyx/pyx-0.12.1.ebuild4
3 files changed, 57 insertions, 4 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index 389c144504a5..409f66cf9bf7 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.30 2012/11/14 07:24:36 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.31 2013/01/27 14:25:26 idella4 Exp $
+
+*pyx-0.12.1-r1 (27 Jan 2013)
+
+ 27 Jan 2013; Ian Delaney <idella4@gentoo.org> +pyx-0.12.1-r1.ebuild,
+ pyx-0.12.1.ebuild:
+ revbump; migrated to distutils-r1, un-needed eutils dropped, fix to building
+ of docs, fixes Bug #453758, thx to flameeyes
*pyx-0.12.1 (14 Nov 2012)
diff --git a/dev-python/pyx/pyx-0.12.1-r1.ebuild b/dev-python/pyx/pyx-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..31410845a083
--- /dev/null
+++ b/dev-python/pyx/pyx-0.12.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.12.1-r1.ebuild,v 1.1 2013/01/27 14:25:26 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS CHANGES )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ cd "${S}/faq"
+ VARTEXFONTS="${T}"/fonts make latexpdf
+ fi
+}
+
+python_install_all() {
+ use doc && dodoc faq/_build/latex/pyxfaq.pdf
+}
diff --git a/dev-python/pyx/pyx-0.12.1.ebuild b/dev-python/pyx/pyx-0.12.1.ebuild
index 1ef9d640e428..df2ad65ed50f 100644
--- a/dev-python/pyx/pyx-0.12.1.ebuild
+++ b/dev-python/pyx/pyx-0.12.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.12.1.ebuild,v 1.1 2012/11/14 07:24:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.12.1.ebuild,v 1.2 2013/01/27 14:25:26 idella4 Exp $
EAPI="3"
PYTHON_DEPEND="2"