summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:54:35 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:54:35 +0000
commita75446b83c318156f93b1fb2409bd35f04ba2088 (patch)
treeeefea742e369312785960e84c7e096b466e29ee1 /dev-python
parentVersion bump (diff)
downloadgentoo-2-a75446b83c318156f93b1fb2409bd35f04ba2088.tar.gz
gentoo-2-a75446b83c318156f93b1fb2409bd35f04ba2088.tar.bz2
gentoo-2-a75446b83c318156f93b1fb2409bd35f04ba2088.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyx/ChangeLog7
-rw-r--r--dev-python/pyx/pyx-0.11.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index 86cd9e94bc59..6d2a5867af18 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.27 2011/01/02 16:15:48 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.28 2011/07/29 22:54:35 bicatali Exp $
+
+*pyx-0.11.1 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +pyx-0.11.1.ebuild:
+ Version bump
02 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-pyx-0.10.ebuild:
diff --git a/dev-python/pyx/pyx-0.11.1.ebuild b/dev-python/pyx/pyx-0.11.1.ebuild
new file mode 100644
index 000000000000..0f5e11bb40fd
--- /dev/null
+++ b/dev-python/pyx/pyx-0.11.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.11.1.ebuild,v 1.1 2011/07/29 22:54:35 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd "${S}/faq"
+ VARTEXFONTS="${T}"/fonts make pdf
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dodoc faq/pyxfaq.pdf
+}