summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-02-20 16:15:35 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-02-20 16:15:35 +0000
commitac020ba679a69ccda8e1fbea06bb29e1b087d3bf (patch)
treec9238be33f0a94207a016f9f392fb098961627de /dev-python
parent~amd64 thanks to lares and cricalix in #gentoo-amd64 (diff)
downloadgentoo-2-ac020ba679a69ccda8e1fbea06bb29e1b087d3bf.tar.gz
gentoo-2-ac020ba679a69ccda8e1fbea06bb29e1b087d3bf.tar.bz2
gentoo-2-ac020ba679a69ccda8e1fbea06bb29e1b087d3bf.zip
version bump
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog8
-rw-r--r--dev-python/PyQt/Manifest22
-rw-r--r--dev-python/PyQt/PyQt-3.13-r1.ebuild62
-rw-r--r--dev-python/PyQt/PyQt-3.14.ebuild62
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.13-r11
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.141
6 files changed, 141 insertions, 15 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index cf0c3eece451..ffb0206bf889 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.51 2005/02/08 05:46:02 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.52 2005/02/20 16:11:15 carlo Exp $
+
+*PyQt-3.13-r1 (20 Feb 2005)
+
+ 20 Feb 2005; Carsten Lohrke <carlo@gentoo.org> +PyQt-3.13-r1.ebuild,
+ +PyQt-3.14.ebuild:
+ version bump
07 Feb 2005; Jeremy Huddleston <eradicator@gentoo.org> PyQt-3.13.ebuild:
Multilib fix for python.
diff --git a/dev-python/PyQt/Manifest b/dev-python/PyQt/Manifest
index aee332b023a1..378ff5c25f1d 100644
--- a/dev-python/PyQt/Manifest
+++ b/dev-python/PyQt/Manifest
@@ -1,22 +1,16 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 ac5934f67a22668b3a25fd0bb87cabe2 ChangeLog 6177
-MD5 5839b01596e10f2cb747c3a15b56e5ae PyQt-3.11.ebuild 1472
MD5 6d0db1c1bdefc35b47486d5e94c491a5 PyQt-3.12.ebuild 1175
-MD5 588b9bd0a512d75531c0d5528a22a427 PyQt-3.13.ebuild 1525
+MD5 cd6983290ccb53857439d03d830f515b PyQt-3.14.ebuild 1641
+MD5 5839b01596e10f2cb747c3a15b56e5ae PyQt-3.11.ebuild 1472
MD5 7ae8c9ca1c90ced05dea52063e8730a8 PyQt-3.8.1.ebuild 1652
+MD5 2dc99b7e77bdf9cf4cd9e0647e1342e3 PyQt-3.13-r1.ebuild 1644
+MD5 087a5882c161bd6b5b5ad1551b4022cc ChangeLog 6314
MD5 811c07ba7510a315382249fc3adb44fc metadata.xml 175
-MD5 c5e3a3d6c377558ef966905f47c9c947 files/PyQt-3.8.1-qt-3.3.patch 280
+MD5 588b9bd0a512d75531c0d5528a22a427 PyQt-3.13.ebuild 1525
MD5 e548a5df6315f902d96d5b2d5afc2901 files/digest-PyQt-3.11 69
MD5 1ce3d5a83afb717de48efb8050e66a1a files/digest-PyQt-3.12 69
MD5 d4df85b93d275ee8302e7ee33998008a files/digest-PyQt-3.13 69
+MD5 c24fadea19e9b29218b912e3ae2be0df files/digest-PyQt-3.14 69
MD5 3fa2049e4d6038c8e02e2069f072cd60 files/digest-PyQt-3.8.1 70
+MD5 d4df85b93d275ee8302e7ee33998008a files/digest-PyQt-3.13-r1 69
+MD5 c5e3a3d6c377558ef966905f47c9c947 files/PyQt-3.8.1-qt-3.3.patch 280
MD5 7323b7d1c141a1f065cb1b8646bec695 files/license-3.8.1.diff 960
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCCFIyArHZZzCEUG0RAsZDAJsEID6akEa4uEfhMVNJfzruNPddhwCeLh3a
-rOSRy6mMeox+DxSoJqDf2As=
-=M32s
------END PGP SIGNATURE-----
diff --git a/dev-python/PyQt/PyQt-3.13-r1.ebuild b/dev-python/PyQt/PyQt-3.13-r1.ebuild
new file mode 100644
index 000000000000..fb8da9817fd2
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.13-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13-r1.ebuild,v 1.1 2005/02/20 16:11:15 carlo Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc -alpha ~amd64 ~ppc64"
+IUSE="debug doc"
+
+RDEPEND="virtual/libc
+ x11-libs/qt
+ dev-lang/python
+ >=dev-python/sip-3.10.2
+ <dev-python/qscintilla-1.6"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
+ -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
+ use debug && myconf="${myconf} -u"
+ has distcc ${FEATURES} || myconf="${myconf} -c"
+
+ if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
+ echo ""
+ einfo "Low on memory?! Use distcc or get a coffee. :)"
+ echo ""
+ fi
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ if use doc ; then
+ dohtml doc/PyQt.html
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/PyQt-3.14.ebuild b/dev-python/PyQt/PyQt-3.14.ebuild
new file mode 100644
index 000000000000..5a871bd4fbf0
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.ebuild,v 1.1 2005/02/20 16:11:15 carlo Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc -alpha ~amd64 ~ppc64"
+IUSE="debug doc"
+
+RDEPEND="virtual/libc
+ x11-libs/qt
+ dev-lang/python
+ >=dev-python/sip-4.2
+ <dev-python/qscintilla-1.6"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
+ -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
+ use debug && myconf="${myconf} -u"
+ has distcc ${FEATURES} || myconf="${myconf} -c"
+
+ if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
+ echo ""
+ einfo "Low on memory?! Use distcc or get a coffee. :)"
+ echo ""
+ fi
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ if use doc ; then
+ dohtml doc/PyQt.html
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.13-r1 b/dev-python/PyQt/files/digest-PyQt-3.13-r1
new file mode 100644
index 000000000000..c64660b67669
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.13-r1
@@ -0,0 +1 @@
+MD5 a4145b39742a4d9df9b6bf06495f75f5 PyQt-x11-gpl-3.13.tar.gz 763066
diff --git a/dev-python/PyQt/files/digest-PyQt-3.14 b/dev-python/PyQt/files/digest-PyQt-3.14
new file mode 100644
index 000000000000..7b817feb77a1
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.14
@@ -0,0 +1 @@
+MD5 a63f0a9e2bd84a110ecbaf6cdf1d956f PyQt-x11-gpl-3.14.tar.gz 782085