summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-23 15:44:37 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-23 15:44:37 +0000
commitb892f4a229545db728179c128876b635eb24b786 (patch)
tree7af73ced06c324b0a2700b5e3eb4c822e5a303f5 /dev-python
parentMove x11-proto/* out of RDEPEND, bug 204781. mips ->~mips to fix deps. (diff)
downloadgentoo-2-b892f4a229545db728179c128876b635eb24b786.tar.gz
gentoo-2-b892f4a229545db728179c128876b635eb24b786.tar.bz2
gentoo-2-b892f4a229545db728179c128876b635eb24b786.zip
Fixed a couple of serious QA issues.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyqwt/ChangeLog6
-rw-r--r--dev-python/pyqwt/pyqwt-4.2-r1.ebuild37
-rw-r--r--dev-python/pyqwt/pyqwt-5.0.1.ebuild62
3 files changed, 67 insertions, 38 deletions
diff --git a/dev-python/pyqwt/ChangeLog b/dev-python/pyqwt/ChangeLog
index 538172516112..0de3dbe87620 100644
--- a/dev-python/pyqwt/ChangeLog
+++ b/dev-python/pyqwt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyqwt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.9 2008/02/23 13:31:42 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.10 2008/02/23 15:44:37 dev-zero Exp $
+
+ 23 Feb 2008; Tiziano Müller <dev-zero@gentoo.org> pyqwt-4.2-r1.ebuild,
+ pyqwt-5.0.1.ebuild:
+ Fixed a couple of serious QA issues.
23 Feb 2008; Tiziano Müller <dev-zero@gentoo.org> -pyqwt-4.2.ebuild:
Dropped old revision.
diff --git a/dev-python/pyqwt/pyqwt-4.2-r1.ebuild b/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
index 6e5b04bd61ac..6bbdf0d65a1b 100644
--- a/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
+++ b/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-4.2-r1.ebuild,v 1.2 2007/07/11 06:19:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-4.2-r1.ebuild,v 1.3 2008/02/23 15:44:37 dev-zero Exp $
-inherit distutils eutils
+NEED_PYTHON="2.3"
-MY_P=PyQwt-${PV}
-S=${WORKDIR}/${MY_P}
+inherit distutils eutils python
+
+MY_P="PyQwt-${PV}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="Python bindings for the Qwt library"
SRC_URI="mirror://sourceforge/pyqwt/${MY_P}.tar.gz"
@@ -16,31 +18,36 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="debug"
-DEPEND=">=dev-lang/python-2.3.2
- ~x11-libs/qwt-4.2.0
+
+RDEPEND="~x11-libs/qwt-4.2.0
>=dev-python/PyQt-3.14
- >=dev-python/sip-4.2
>=dev-python/numarray-1.1.1
>=dev-python/numeric-23.7"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.2"
src_compile() {
- cd ${S}/sip
+ cd "${S}/sip"
sed -i s/"[[:space:]]*const QLabel \*titleLabel() const\;"// qwtplot.sip
sed -i s/"[[:space:]]*const QwtPlotCanvas \*canvas() const\;"// qwtplot.sip
- cd ${S}/configure
+ cd "${S}/configure"
local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -l /usr/$(get_libdir) \
-i /usr/include/qwt -v /usr/share/sip -x /usr/share/sip"
use debug && myconf="${myconf} -u"
has distcc ${FEATURES} || myconf="${myconf} -c"
- python configure.py ${myconf}
+
+ python_version
+ "${python}" configure.py ${myconf} || die "python configure.py failed"
emake || die "emake failed"
}
src_install() {
- cd ${S}
+ cd "${S}"
sed -i s/2,4,9/2,5,9/ setup.py
- python setup.py install --prefix=/usr --root=${D} || die "install failed"
+
+ python_version
+ "${python}" setup.py install --prefix=/usr --root="${D}" || die "install failed"
dodoc ANNOUNCEMENT-4.2.TXT AUTHORS COPYING* README THANKS
- use doc && mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${PF}
- rm -rf ${D}/usr/share/doc/${MY_P}
+ use doc && mv "${D}/usr/share/doc/${MY_P}"/* "${D}/usr/share/doc/${PF}"
+ rm -rf "${D}/usr/share/doc/${MY_P}"
}
diff --git a/dev-python/pyqwt/pyqwt-5.0.1.ebuild b/dev-python/pyqwt/pyqwt-5.0.1.ebuild
index 4f3d5c47a9b3..41b93196a882 100644
--- a/dev-python/pyqwt/pyqwt-5.0.1.ebuild
+++ b/dev-python/pyqwt/pyqwt-5.0.1.ebuild
@@ -1,48 +1,66 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.0.1.ebuild,v 1.4 2008/01/14 19:19:27 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.0.1.ebuild,v 1.5 2008/02/23 15:44:37 dev-zero Exp $
-inherit eutils
+EAPI="1"
+inherit eutils python toolchain-funcs
-MY_P=PyQwt-${PV}
-S=${WORKDIR}/${MY_P}
+MY_P="PyQwt-${PV}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="Python bindings for the Qwt library"
SRC_URI="mirror://sourceforge/pyqwt/${MY_P}.tar.gz"
HOMEPAGE="http://pyqwt.sourceforge.net/"
-
SLOT="5"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="debug doc examples"
-DEPEND="virtual/python
- =x11-libs/qwt-5*
+RDEPEND="virtual/python
+ x11-libs/qwt:5
>=dev-python/PyQt4-4.2
- >=dev-python/sip-4.1.1
>=dev-python/numpy-1.0.1"
+DEPEND="${DEPEND}
+ >=dev-python/sip-4.1.1"
+
+src_unpack() {
+ unpack ${A}
-src_compile() {
- cd ${S}/sip/qwt5qt4
# PyQwt CVS does not need the next 2 sed statements anymore
- sed -i "s|%Import QtSvg/QtSvgmod.sip||" QwtModule.sip
- sed -i "s|%Include qwt_plot_svgitem.sip||" QwtModule.sip
+ sed -i \
+ -e "s|%Import QtSvg/QtSvgmod.sip||" \
+ -e "s|%Include qwt_plot_svgitem.sip||" \
+ "${S}/sip/qwt5qt4/QwtModule.sip" || die "sed failed"
+
+ # Avoid pre-stripped files
+ sed -i \
+ -e 's|ModuleMakefile(|ModuleMakefile(strip=0,|' \
+ "${S}/configure/configure.py" || die "sed failed"
+}
+
+src_compile() {
cd "${S}/configure"
- local myconf="-I /usr/include/qwt5 -l qwt --disable-numarray --disable-numeric"
+
+ local myconf="-I/usr/include/qwt5 -lqwt --disable-numarray --disable-numeric"
use debug && myconf="${myconf} --debug"
- has distcc ${FEATURES} || myconf="${myconf} -j 1"
- python configure.py ${myconf}
- emake || die "emake failed"
+ has distcc ${FEATURES} || myconf="${myconf} -j1"
+
+ python_version
+ "${python}" configure.py ${myconf} || die "python configure.py failed"
+ emake CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "emake failed"
}
src_install() {
cd "${S}/configure"
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
+
cd "${S}"
dodoc ANNOUNCEMENT-${PV} CHANGES-${PV} COPYING* README
- use doc && dohtml Doc/html/pyqwt/*
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r qt4examples/ "${D}/usr/share/doc/${PF}/examples"
- fi
+
+ use doc && dohtml Doc/html/pyqwt/*
+
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r qt4examples/ "${D}/usr/share/doc/${PF}/examples"
+ fi
}