summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-04-06 12:18:13 +0000
committerAli Polatel <hawking@gentoo.org>2008-04-06 12:18:13 +0000
commitbbce2032cb29bf1ec1dfa4fb6c4cd4c0d18b7b55 (patch)
tree91d87ec1077238b03a21d0d2037f296da1606c3c /dev-python
parentVersion bump many thanks to AngelKnight <lance@jound.net> in bug 205799 (diff)
downloadgentoo-2-bbce2032cb29bf1ec1dfa4fb6c4cd4c0d18b7b55.tar.gz
gentoo-2-bbce2032cb29bf1ec1dfa4fb6c4cd4c0d18b7b55.tar.bz2
gentoo-2-bbce2032cb29bf1ec1dfa4fb6c4cd4c0d18b7b55.zip
Version bump. Dropped ogre use flag, bug 210731. Added src_test.
(Portage version: 2.1.5_rc1)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cgkit/ChangeLog9
-rw-r--r--dev-python/cgkit/cgkit-2.0.0_alpha8.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-python/cgkit/ChangeLog b/dev-python/cgkit/ChangeLog
index a3ca011243b6..1344901c2ab6 100644
--- a/dev-python/cgkit/ChangeLog
+++ b/dev-python/cgkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cgkit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.19 2007/11/13 06:55:42 opfer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.20 2008/04/06 12:18:13 hawking Exp $
+
+*cgkit-2.0.0_alpha8 (06 Apr 2008)
+
+ 06 Apr 2008; Ali Polatel <hawking@gentoo.org> +cgkit-2.0.0_alpha8.ebuild:
+ Version bump. Dropped ogre use flag, bug 210731. Added src_test.
13 Nov 2007; Christian Faulhammer <opfer@gentoo.org>
cgkit-2.0.0_alpha7.ebuild:
diff --git a/dev-python/cgkit/cgkit-2.0.0_alpha8.ebuild b/dev-python/cgkit/cgkit-2.0.0_alpha8.ebuild
new file mode 100644
index 000000000000..0285f6d1b557
--- /dev/null
+++ b/dev-python/cgkit/cgkit-2.0.0_alpha8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-2.0.0_alpha8.ebuild,v 1.1 2008/04/06 12:18:13 hawking Exp $
+
+inherit distutils flag-o-matic
+
+MY_P=${P/_/}
+DESCRIPTION="Python library for creating 3D images"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://cgkit.sourceforge.net"
+DEPEND="dev-lang/python
+ dev-python/pyrex
+ dev-util/scons
+ dev-libs/boost
+ dev-python/pyprotocols
+ dev-python/numarray
+ dev-python/pyopengl
+ dev-python/pygame
+ dev-python/imaging
+ 3ds? ( media-libs/lib3ds )"
+SLOT="0"
+LICENSE="LGPL-2.1 MPL-1.1 GPL-2"
+KEYWORDS="~ppc ~x86"
+IUSE="3ds"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/fPIC/fPIC\",\"${CFLAGS// /\",\"}/" supportlib/SConstruct
+ cp config_template.cfg config.cfg
+ echo 'LIBS += ["GL", "GLU", "glut"]' >> config.cfg
+ if use 3ds; then
+ echo 'LIB3DS_AVAILABLE = True' >> config.cfg
+ fi
+
+ # Ogre viewer is no longer maintained by upstream
+ # bug 210731
+ #if use ogre; then
+ # echo 'OGRE_AVAILABLE = True' >> config.cfg
+ # echo 'INC_DIRS += ["/usr/include/OGRE"]' >> config.cfg
+ # echo 'MACROS += [("EXT_HASH", None),("GCC_3_1",None)]' >> config.cfg
+ # sed -i -e "s/#include <Math.h>//" wrappers/ogre/OgreCore.h
+ #fi
+
+ sed -i -e "s:INC_DIRS = \[\]:INC_DIRS = \['/usr/include'\]:" "${S}"/setup.py
+}
+
+src_compile() {
+ cd "${S}"/supportlib
+ scons ${MAKEOPTS}
+ cd "${S}"
+ distutils_src_compile
+}
+
+src_test() {
+ cd unittests
+ # Remove failing tests due to non-existing files
+ rm test_maimport.py test_mayaascii.py test_mayabinary.py test_ri.py \
+ test_slparams.py
+ PYTHONPATH=$(ls -d ../build/lib*) ${python} all.py || die "tests failed"
+}