summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-12-20 10:53:01 +0000
committerFabian Groffen <grobian@gentoo.org>2009-12-20 10:53:01 +0000
commitcb4c2dca90c832a3e10407dbe715268a9618fb33 (patch)
tree3de4bfa4cac04a0523c7e21e6520ab53854244d5 /dev-python
parentMerged keywords from Prefix overlay (diff)
downloadgentoo-2-cb4c2dca90c832a3e10407dbe715268a9618fb33.tar.gz
gentoo-2-cb4c2dca90c832a3e10407dbe715268a9618fb33.tar.bz2
gentoo-2-cb4c2dca90c832a3e10407dbe715268a9618fb33.zip
Merged keywords from Prefix overlay, applied fixes for Prefix and Darwin (bug #295035)
(Portage version: 2.2.00.15118-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog9
-rw-r--r--dev-python/sip/files/sip-4.9.3-darwin.patch41
-rw-r--r--dev-python/sip/sip-4.9.3-r1.ebuild77
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 47734016c531..3ded2190e6a2 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.151 2009/11/23 17:32:23 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.152 2009/12/20 10:53:01 grobian Exp $
+
+*sip-4.9.3-r1 (20 Dec 2009)
+
+ 20 Dec 2009; Fabian Groffen <grobian@gentoo.org> +sip-4.9.3-r1.ebuild,
+ +files/sip-4.9.3-darwin.patch:
+ Merged keywords from Prefix overlay, applied fixes for Prefix and Darwin
+ (bug #295035)
*sip-4.9.3 (23 Nov 2009)
diff --git a/dev-python/sip/files/sip-4.9.3-darwin.patch b/dev-python/sip/files/sip-4.9.3-darwin.patch
new file mode 100644
index 000000000000..c82b727f3d2f
--- /dev/null
+++ b/dev-python/sip/files/sip-4.9.3-darwin.patch
@@ -0,0 +1,41 @@
+Don't require a framework builds, and produce .bundle files
+
+--- siputils.py
++++ siputils.py
+@@ -818,8 +818,6 @@
+ """
+ if self.generator in ("MSVC", "MSVC.NET", "BMAKE"):
+ plib = clib + ".lib"
+- elif sys.platform == "darwin" and framework:
+- plib = "-framework " + clib
+ else:
+ plib = "-l" + clib
+
+@@ -836,8 +834,6 @@
+
+ if self.generator in ("MSVC", "MSVC.NET", "BMAKE"):
+ prl_name = os.path.join(self.config.qt_lib_dir, clib + ".prl")
+- elif sys.platform == "darwin" and framework:
+- prl_name = os.path.join(self.config.qt_lib_dir, clib + ".framework", clib + ".prl")
+ else:
+ prl_name = os.path.join(self.config.qt_lib_dir, "lib" + clib + ".prl")
+
+@@ -1396,9 +1392,6 @@
+ # 'real_prefix' exists if virtualenv is being used.
+ dl = getattr(sys, 'real_prefix', sys.exec_prefix).split(os.sep)
+
+- if "Python.framework" not in dl:
+- error("SIP requires Python to be built as a framework")
+-
+ self.LFLAGS.append("-undefined dynamic_lookup")
+
+ Makefile.finalise(self)
+@@ -1478,7 +1471,7 @@
+ if sys.platform == "win32":
+ ext = "pyd"
+ elif sys.platform == "darwin":
+- ext = "so"
++ ext = "bundle"
+ elif sys.platform == "cygwin":
+ ext = "dll"
+ else:
diff --git a/dev-python/sip/sip-4.9.3-r1.ebuild b/dev-python/sip/sip-4.9.3-r1.ebuild
new file mode 100644
index 000000000000..fdb9ae214910
--- /dev/null
+++ b/dev-python/sip/sip-4.9.3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.9.3-r1.ebuild,v 1.1 2009/12/20 10:53:01 grobian Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python toolchain-funcs eutils
+
+MY_P=${P/_pre/-snapshot-}
+
+DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin.patch
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py
+ --bindir=${EPREFIX}/usr/bin
+ --destdir=${EPREFIX}$(python_get_sitedir)
+ --incdir=${EPREFIX}$(python_get_includedir)
+ --sipdir=${EPREFIX}/usr/share/sip
+ $(use debug && echo '--debug')
+ CC=$(tc-getCC) CXX=$(tc-getCXX)
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
+ CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
+ LFLAGS='${LDFLAGS}'
+ STRIP=true"
+ echo ${myconf}
+ eval ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ python_need_rebuild
+
+ python_execute_function -d -s
+
+ dodoc ChangeLog NEWS || die
+
+ if use doc; then
+ dohtml -r doc/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+
+ ewarn 'When updating sip, you usually need to recompile packages that'
+ ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
+ ewarn 'app-portage/gentoolkit installed you can find these packages with'
+ ewarn '`equery d sip` and `equery d PyQt4`.'
+}
+
+pkg_postrm() {
+ python_mod_cleanup sipconfig.py sipdistutils.py
+}