summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Kingsley <tercel@gentoo.org>2005-06-01 16:33:25 +0000
committerColin Kingsley <tercel@gentoo.org>2005-06-01 16:33:25 +0000
commitd4f23d3645fcb6552e4e60ac01c5a13d1d004186 (patch)
tree7d9ab52ced3aafefbe041699c32a79e7b5ccb18b /dev-python
parentfix smeg (diff)
downloadgentoo-2-d4f23d3645fcb6552e4e60ac01c5a13d1d004186.tar.gz
gentoo-2-d4f23d3645fcb6552e4e60ac01c5a13d1d004186.tar.bz2
gentoo-2-d4f23d3645fcb6552e4e60ac01c5a13d1d004186.zip
Fix use flag conditionals in src_compile
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/visual/Manifest2
-rw-r--r--dev-python/visual/visual-3.2.1.ebuild18
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-python/visual/Manifest b/dev-python/visual/Manifest
index 11f0fa0eb66d..b256d44d6218 100644
--- a/dev-python/visual/Manifest
+++ b/dev-python/visual/Manifest
@@ -1,4 +1,4 @@
MD5 9f743338261e6f4f2a1313e13b5937e8 ChangeLog 326
MD5 dc0b1d0f6421b62d34ca91dd8ac2d52d metadata.xml 255
-MD5 e758aba2cc1ff0b6e5e400a63356d77b visual-3.2.1.ebuild 1529
+MD5 132ea645bed0c183b76bed65cded743a visual-3.2.1.ebuild 1638
MD5 6d6e6100c2055b0082f7ddbee8f2d1e2 files/digest-visual-3.2.1 65
diff --git a/dev-python/visual/visual-3.2.1.ebuild b/dev-python/visual/visual-3.2.1.ebuild
index 0194877e1a0c..93f43119a199 100644
--- a/dev-python/visual/visual-3.2.1.ebuild
+++ b/dev-python/visual/visual-3.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-3.2.1.ebuild,v 1.2 2005/06/01 02:21:00 tercel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-3.2.1.ebuild,v 1.3 2005/06/01 16:33:25 tercel Exp $
inherit distutils
@@ -23,15 +23,24 @@ DEPEND=">=dev-lang/python-2.3
numarray? ( >=dev-python/numarray-1.0 )
!numeric? ( !numarray? (dev-python/numeric) )"
+RESTRICT="nomirror"
+
src_compile() {
+ local myconf="--without-numarray --without-numeric"
+
echo
if useq numeric; then
einfo "Building with Numeric support"
- elif useq numarray; then
+ myconf=${myconf/--without-numeric}
+ fi
+ if useq numarray; then
einfo "Building with Numarray support"
- else
+ myconf=${myconf/--without-numarray}
+ fi
+ if ! useq numeric && ! useq numarray; then
einfo "Support for Numeric or Numarray was not specified."
einfo "Building with Numeric support"
+ myconf=${myconf/--without-numarray}
fi
echo
@@ -40,6 +49,7 @@ src_compile() {
--with-example-dir=/usr/share/doc/${PF}/examples \
$(use_enable doc docs ) \
$(use_enable examples ) \
+ ${myconf} \
|| die "configure failed"
emake || die "emake failed"