summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-19 15:51:27 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-19 15:51:27 +0000
commitd833d710c3484e76f5608aaf5c61e00c16c18643 (patch)
tree0a5535aa70909d8bdf3ef5b2ed3d517a44a1b5ae /dev-python
parentclean old python impls, add pypy3 support (diff)
downloadgentoo-2-d833d710c3484e76f5608aaf5c61e00c16c18643.tar.gz
gentoo-2-d833d710c3484e76f5608aaf5c61e00c16c18643.tar.bz2
gentoo-2-d833d710c3484e76f5608aaf5c61e00c16c18643.zip
Add pypy3 support, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests/ChangeLog6
-rw-r--r--dev-python/requests/requests-1.2.3.ebuild46
-rw-r--r--dev-python/requests/requests-2.4.0.ebuild40
-rw-r--r--dev-python/requests/requests-2.4.3.ebuild4
4 files changed, 7 insertions, 89 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index 4b3919a13143..c65e62703ae5 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.78 2014/10/14 03:37:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.79 2014/11/19 15:51:27 idella4 Exp $
+
+ 19 Nov 2014; Ian Delaney <idella4@gentoo.org> -requests-1.2.3.ebuild,
+ -requests-2.4.0.ebuild, requests-2.4.3.ebuild:
+ Add pypy3 support, rm old
*requests-2.4.3 (14 Oct 2014)
diff --git a/dev-python/requests/requests-1.2.3.ebuild b/dev-python/requests/requests-1.2.3.ebuild
deleted file mode 100644
index ba9dff0769fe..000000000000
--- a/dev-python/requests/requests-1.2.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.2.3.ebuild,v 1.7 2014/06/08 17:03:48 hattya Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 x86"
-IUSE="test"
-
-# bundles dev-python/urllib3 snapshot
-RDEPEND="app-misc/ca-certificates
- dev-python/charade[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-DOCS=( README.rst HISTORY.rst )
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${PN}-1.2.0-system-cacerts.patch
- "${FILESDIR}"/${PN}-1.2.0-system-libs.patch
- "${FILESDIR}"/${PN}-1.2.1-urllib3-py3.patch
- )
-
- # use system charade
- rm -r requests/packages/charade || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/requests/requests-2.4.0.ebuild b/dev-python/requests/requests-2.4.0.ebuild
deleted file mode 100644
index ec05f1bfce9d..000000000000
--- a/dev-python/requests/requests-2.4.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.4.0.ebuild,v 1.1 2014/09/09 06:47:52 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-# bundles dev-python/urllib3 snapshot
-RDEPEND="app-misc/ca-certificates
- >=dev-python/chardet-2.2.1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.2.0-system-chardet.patch \
- "${FILESDIR}"/${P}-system-cacerts.patch )
-
-python_prepare_all() {
- # use system chardet
- rm -r requests/packages/chardet || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" test_requests.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/requests/requests-2.4.3.ebuild b/dev-python/requests/requests-2.4.3.ebuild
index 837114f32290..abc06b38c1e4 100644
--- a/dev-python/requests/requests-2.4.3.ebuild
+++ b/dev-python/requests/requests-2.4.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.4.3.ebuild,v 1.1 2014/10/14 03:37:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.4.3.ebuild,v 1.2 2014/11/19 15:51:27 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1