summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-30 18:29:35 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-30 18:29:35 +0000
commitdd4ded22757577a9a3a3b041f8496f7742abc193 (patch)
treeb58302bb22957928aa6b51c9126b98ffb9513dac /dev-python
parentAdding ~x86 masked selinux-sources (diff)
downloadgentoo-2-dd4ded22757577a9a3a3b041f8496f7742abc193.tar.gz
gentoo-2-dd4ded22757577a9a3a3b041f8496f7742abc193.tar.bz2
gentoo-2-dd4ded22757577a9a3a3b041f8496f7742abc193.zip
wxPython done properly (without wxGTK)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxPython/ChangeLog12
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.3.3.1-r21
-rw-r--r--dev-python/wxPython/files/wxPython-2.3.3.1-noglcanvas.diff93
-rw-r--r--dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild54
4 files changed, 157 insertions, 3 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 16734f569c6d..f60b4d440b4e 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.11 2002/10/29 18:17:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.12 2002/10/30 18:29:35 vapier Exp $
-*wxPython-2.3.3.1-r1 (28 Oct 2002)
+*wxPython-2.3.3.1-r2 (30 Oct 2002)
- 28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ 30 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Removed all the crap put into the first 2.3.3.1 ebuild to build wxGTK and
+ updated the patch to remove glcanvas
+
+*wxPython-2.3.3.1-r1 (29 Oct 2002)
+
+ 29 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
added some changes per discussion on #9693
*wxPython-2.3.3.1 (28 Oct 2002)
diff --git a/dev-python/wxPython/files/digest-wxPython-2.3.3.1-r2 b/dev-python/wxPython/files/digest-wxPython-2.3.3.1-r2
new file mode 100644
index 000000000000..d8ba57c02af6
--- /dev/null
+++ b/dev-python/wxPython/files/digest-wxPython-2.3.3.1-r2
@@ -0,0 +1 @@
+MD5 ba09626f1ff92304677a473b870bcb24 wxPythonSrc-2.3.3.1.tar.gz 11143374
diff --git a/dev-python/wxPython/files/wxPython-2.3.3.1-noglcanvas.diff b/dev-python/wxPython/files/wxPython-2.3.3.1-noglcanvas.diff
new file mode 100644
index 000000000000..0c9462e1914f
--- /dev/null
+++ b/dev-python/wxPython/files/wxPython-2.3.3.1-noglcanvas.diff
@@ -0,0 +1,93 @@
+diff -urN wxPython-2.3.2.1/setup.py wxPython-2.3.2.1-modified/setup.py
+--- wxPython-2.3.2.1/setup.py Thu Dec 20 11:33:42 2001
++++ wxPython-2.3.2.1-modified/setup.py Thu Aug 22 14:04:04 2002
+@@ -28,7 +28,7 @@
+ """
+
+
+-BUILD_GLCANVAS = 1 # If true, build the contrib/glcanvas extension module
++BUILD_GLCANVAS = 0 # If true, build the contrib/glcanvas extension module
+ BUILD_OGL = 1 # If true, build the contrib/ogl extension module
+ BUILD_STC = 1 # If true, build the contrib/stc extension module
+ BUILD_XRC = 1 # XML based resource system
+@@ -500,43 +500,43 @@
+ #----------------------------------------------------------------------
+ # Define the GLCanvas extension module
+ #----------------------------------------------------------------------
+-
+-CTRB_SRC = opj(WXDIR, 'contrib/src')
+-CTRB_INC = opj(WXDIR, 'contrib/include/wx')
+-
+-if BUILD_GLCANVAS or GL_ONLY:
+- msg('Preparing GLCANVAS...')
+- location = 'contrib/glcanvas'
+- swig_files = ['glcanvas.i']
+- other_sources = []
+-
+- swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
+- USE_SWIG, swig_force, swig_args, swig_deps)
+-
+- gl_libs = []
+- if os.name == 'posix':
+- gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
+- gl_lflags = string.split(gl_config) + lflags
+- gl_libs = libs
+- else:
+- other_sources = [opj(location, 'msw/myglcanvas.cpp')]
+- gl_libs = libs + ['opengl32', 'glu32']
+- gl_lflags = lflags
+-
+- ext = Extension('glcanvasc',
+- swig_sources + other_sources,
+-
+- include_dirs = includes,
+- define_macros = defines,
+-
+- library_dirs = libdirs,
+- libraries = gl_libs,
+-
+- extra_compile_args = cflags,
+- extra_link_args = gl_lflags,
+- )
+-
+- wxpExtensions.append(ext)
++#
++#CTRB_SRC = opj(WXDIR, 'contrib/src')
++#CTRB_INC = opj(WXDIR, 'contrib/include/wx')
++#
++#if BUILD_GLCANVAS or GL_ONLY:
++# msg('Preparing GLCANVAS...')
++# location = 'contrib/glcanvas'
++# swig_files = ['glcanvas.i']
++# other_sources = []
++#
++# swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
++# USE_SWIG, swig_force, swig_args, swig_deps)
++#
++# gl_libs = []
++# if os.name == 'posix':
++# gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
++# gl_lflags = string.split(gl_config) + lflags
++# gl_libs = libs
++# else:
++# other_sources = [opj(location, 'msw/myglcanvas.cpp')]
++# gl_libs = libs + ['opengl32', 'glu32']
++# gl_lflags = lflags
++#
++# ext = Extension('glcanvasc',
++# swig_sources + other_sources,
++#
++# include_dirs = includes,
++# define_macros = defines,
++#
++# library_dirs = libdirs,
++# libraries = gl_libs,
++#
++# extra_compile_args = cflags,
++# extra_link_args = gl_lflags,
++# )
++#
++# wxpExtensions.append(ext)
+
+
+ #----------------------------------------------------------------------
diff --git a/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild b/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild
new file mode 100644
index 000000000000..cca5aea784a3
--- /dev/null
+++ b/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild,v 1.1 2002/10/30 18:29:35 vapier Exp $
+
+IUSE="opengl"
+
+MY_P="${P/-/Src-}"
+S="${WORKDIR}/${MY_P}/${PN}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python."
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
+HOMEPAGE="http://www.wxpython.org/"
+
+DEPEND=">=dev-lang/python-2.1
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ =x11-libs/wxGTK-2.3.3*
+ opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+pkg_setup() {
+ # xfree should not install these, remove until the fixed
+ # xfree is in main use.
+ rm -f /usr/X11R6/include/{zconf.h,zlib.h}
+}
+
+src_compile() {
+ # create links so the build doesnt fail
+ for d in ogl stc xrc gizmos ; do
+ ln -s ${S}/../contrib/ ${S}/contrib/${d}/contrib
+ done
+
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+
+ local myconf=""
+ if [ `use opengl` ] ; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ patch -p1 < ${FILESDIR}/${P}-noglcanvas.diff || die "patch failed"
+ fi
+
+ python setup.py ${myconf} build || die
+}
+
+src_install() {
+ python setup.py install --prefix=/usr --root=${D} || die
+}