summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-11 05:43:02 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-11 05:43:02 +0000
commite01bfffdf26e0b43f5a852266ddd4ce243141e18 (patch)
treeb633c9402b9b22f5ccb1d1ecdaca3a63f326ceea /dev-python
parentCleanup. (diff)
downloadgentoo-2-e01bfffdf26e0b43f5a852266ddd4ce243141e18.tar.gz
gentoo-2-e01bfffdf26e0b43f5a852266ddd4ce243141e18.tar.bz2
gentoo-2-e01bfffdf26e0b43f5a852266ddd4ce243141e18.zip
revbump, migration -> distutils-r1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/translationstring/ChangeLog11
-rw-r--r--dev-python/translationstring/translationstring-1.1-r1.ebuild41
2 files changed, 49 insertions, 3 deletions
diff --git a/dev-python/translationstring/ChangeLog b/dev-python/translationstring/ChangeLog
index 92bb145b599a..840be1712e0b 100644
--- a/dev-python/translationstring/ChangeLog
+++ b/dev-python/translationstring/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/translationstring
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/ChangeLog,v 1.8 2012/02/22 23:12:14 marienz Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/ChangeLog,v 1.9 2013/04/11 05:43:02 idella4 Exp $
+
+*translationstring-1.1-r1 (11 Apr 2013)
+
+ 11 Apr 2013; Ian Delaney <idella4@gentoo.org>
+ +translationstring-1.1-r1.ebuild:
+ revbump, migration -> distutils-r1
22 Feb 2012; Marien Zwart <marienz@gentoo.org> translationstring-1.1.ebuild:
Fix unnecessarily strict PYTHON_DEPEND.
@@ -40,4 +46,3 @@
30 Jul 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+translationstring-0.3.ebuild, +metadata.xml:
Initial version. Based on ebuild by Jan Matějka (bug #353769).
-
diff --git a/dev-python/translationstring/translationstring-1.1-r1.ebuild b/dev-python/translationstring/translationstring-1.1-r1.ebuild
new file mode 100644
index 000000000000..2d1a03222972
--- /dev/null
+++ b/dev-python/translationstring/translationstring-1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/translationstring-1.1-r1.ebuild,v 1.1 2013/04/11 05:43:02 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for i18n relied on by various Repoze packages"
+HOMEPAGE="https://github.com/Pylons/translationstring http://pypi.python.org/pypi/translationstring"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.txt README.txt COPYRIGHT.txt )
+
+python_test() {
+ esetup.py test || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires a
+ # theme only available from git that contains hardcoded references
+ # to files on https://static.pylonsproject.org/ (so the docs would
+ # not actually work offline). Install into a "docs" subdirectory
+ # so the reference in the README remains correct.
+ docinto docs
+ docompress -x usr/share/doc/${PF}/docs
+ dodoc docs/*.rst
+}