summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-07-15 13:48:01 +0000
committerJeroen Roovers <jer@gentoo.org>2009-07-15 13:48:01 +0000
commite2a8bc6c9a9df9f853e654e03eab71b3e9aea4c6 (patch)
tree458499dba3934e969f320e80b3eec40daa994e1d /dev-python
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e2a8bc6c9a9df9f853e654e03eab71b3e9aea4c6.tar.gz
gentoo-2-e2a8bc6c9a9df9f853e654e03eab71b3e9aea4c6.tar.bz2
gentoo-2-e2a8bc6c9a9df9f853e654e03eab71b3e9aea4c6.zip
Check for __hppa__ not __parisc__ (bug #277438).
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numpy/ChangeLog6
-rw-r--r--dev-python/numpy/files/numpy-1.3.0-parisc.patch11
-rw-r--r--dev-python/numpy/numpy-1.3.0.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 50333c513cc8..827c334bc13b 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.83 2009/07/15 13:04:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.84 2009/07/15 13:48:01 jer Exp $
+
+ 15 Jul 2009; Jeroen Roovers <jer@gentoo.org> numpy-1.3.0.ebuild,
+ +files/numpy-1.3.0-parisc.patch:
+ Check for __hppa__ not __parisc__ (bug #277438).
15 Jul 2009; Christian Faulhammer <fauli@gentoo.org> numpy-1.3.0.ebuild:
stable x86, bug 277354
diff --git a/dev-python/numpy/files/numpy-1.3.0-parisc.patch b/dev-python/numpy/files/numpy-1.3.0-parisc.patch
new file mode 100644
index 000000000000..232a568933c1
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.3.0-parisc.patch
@@ -0,0 +1,11 @@
+--- numpy-1.3.0/numpy/core/include/numpy/npy_cpu.h.orig 2009-04-05 10:09:20.000000000 +0200
++++ numpy-1.3.0/numpy/core/include/numpy/npy_cpu.h 2009-07-15 15:29:15.000000000 +0200
+@@ -42,7 +42,7 @@
+ #define NPY_CPU_S390
+ #elif defined(__ia64)
+ #define NPY_CPU_IA64
+-#elif defined(__parisc__)
++#elif defined(__hppa__)
+ /* XXX: Not sure about this one... */
+ #define NPY_CPU_PARISC
+ #else
diff --git a/dev-python/numpy/numpy-1.3.0.ebuild b/dev-python/numpy/numpy-1.3.0.ebuild
index 036807ee1086..165877b82329 100644
--- a/dev-python/numpy/numpy-1.3.0.ebuild
+++ b/dev-python/numpy/numpy-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0.ebuild,v 1.3 2009/07/15 13:04:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0.ebuild,v 1.4 2009/07/15 13:48:01 jer Exp $
NEED_PYTHON=2.4
EAPI=2
@@ -43,6 +43,8 @@ src_prepare() {
# Fix some paths and docs in f2py
epatch "${FILESDIR}"/${PN}-1.1.0-f2py.patch
+ epatch "${FILESDIR}/${P}-parisc.patch" # bug 277438
+
# Gentoo patch for ATLAS library names
sed -i \
-e "s:'f77blas':'blas':g" \