summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-29 17:46:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-29 17:46:19 +0000
commiteb91f01c6a6f9eedf97f4043474f1e6fa45677dd (patch)
tree58f4e5ca4a16a4b9d7fcd6ffb803486228299c57 /dev-python
parentAdd ~sparc (diff)
downloadgentoo-2-eb91f01c6a6f9eedf97f4043474f1e6fa45677dd.tar.gz
gentoo-2-eb91f01c6a6f9eedf97f4043474f1e6fa45677dd.tar.bz2
gentoo-2-eb91f01c6a6f9eedf97f4043474f1e6fa45677dd.zip
Use PYTHON_MODNAME.
(Portage version: 14920-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipy/ipy-0.70.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/ipy/ipy-0.70.ebuild b/dev-python/ipy/ipy-0.70.ebuild
index 2e98bdd06c22..c6b06e78f431 100644
--- a/dev-python/ipy/ipy-0.70.ebuild
+++ b/dev-python/ipy/ipy-0.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.70.ebuild,v 1.1 2009/10/30 20:19:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.70.ebuild,v 1.2 2009/11/29 17:46:19 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -25,17 +25,11 @@ RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="IPy.py"
+
src_test() {
testing() {
PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_IPy.py
}
python_execute_function testing
}
-
-pkg_postinst() {
- python_mod_optimize IPy.py
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}