summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-01-29 18:40:02 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-01-29 18:40:02 +0000
commitec91d58ac5895c81fd6e26ada971acfc586e7241 (patch)
tree9d2825cbf04a762aa01aa5b792a1b23f041c3836 /dev-python
parentStable for HPPA (bug #452596). (diff)
downloadgentoo-2-ec91d58ac5895c81fd6e26ada971acfc586e7241.tar.gz
gentoo-2-ec91d58ac5895c81fd6e26ada971acfc586e7241.tar.bz2
gentoo-2-ec91d58ac5895c81fd6e26ada971acfc586e7241.zip
Migrate to the new python eclass.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog9
-rw-r--r--dev-python/sip/sip-4.14.2-r1.ebuild120
2 files changed, 127 insertions, 2 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 276bc50f29f6..e27e026cc077 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.234 2012/12/26 03:18:38 pesa Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.235 2013/01/29 18:40:02 kensington Exp $
+
+*sip-4.14.2-r1 (29 Jan 2013)
+
+ 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +sip-4.14.2-r1.ebuild:
+ Migrate to the new python eclass.
26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -sip-4.14.1.ebuild:
old
diff --git a/dev-python/sip/sip-4.14.2-r1.ebuild b/dev-python/sip/sip-4.14.2-r1.ebuild
new file mode 100644
index 000000000000..077267a51834
--- /dev/null
+++ b/dev-python/sip/sip-4.14.2-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.14.2-r1.ebuild,v 1.1 2013/01/29 18:40:02 kensington Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+inherit eutils python-r1 toolchain-funcs
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+
+if [[ ${PV} == *9999* ]]; then
+ # live version from mercurial repo
+ EHG_REPO_URI="http://www.riverbankcomputing.com/hg/sip"
+ inherit mercurial
+elif [[ ${PV} == *_pre* ]]; then
+ # development snapshot
+ HG_REVISION=
+ MY_P=${PN}-${PV%_pre*}-snapshot-${HG_REVISION}
+ SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+else
+ # official release
+ SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
+fi
+
+# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
+SLOT="0/9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == *9999* ]] && DEPEND+="
+ =dev-lang/python-2*
+ sys-devel/bison
+ sys-devel/flex
+ doc? ( dev-python/sphinx[$(python_gen_usedep python2*)] )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
+
+ if [[ ${PV} == *9999* ]]; then
+ python2 build.py prepare || die
+ if use doc; then
+ python2 build.py doc || die
+ fi
+ fi
+
+ # Sub-slot sanity check
+ local sub_slot=${SLOT#*/}
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
+ if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ pushd "${BUILD_DIR}" > /dev/null
+ local myconf=(
+ "${PYTHON}" configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --incdir="${EPREFIX}$(python_get_includedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ $(use debug && echo --debug)
+ AR="$(tc-getAR) cqs"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CFLAGS_RELEASE=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ CXXFLAGS_RELEASE=
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ LFLAGS="${LDFLAGS}"
+ LFLAGS_RELEASE=
+ RANLIB=
+ STRIP=
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ popd > /dev/null
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ compilation() {
+ pushd "${BUILD_DIR}" > /dev/null
+ default
+ popd > /dev/null
+ }
+ python_foreach_impl compilation
+}
+
+src_install() {
+ installation() {
+ pushd "${BUILD_DIR}" > /dev/null
+ emake DESTDIR="${D}" install
+ python_optimize
+ popd > /dev/null
+ }
+ python_foreach_impl installation
+
+ dodoc NEWS
+ use doc && dohtml -r doc/html/*
+}