summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-10 13:23:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-10 13:23:50 +0000
commitf3c0cd7d9d2cbd7189093652957f013587c453d4 (patch)
tree0c499ef3cea7d00bd6ebad573fc1ff01acde452c /dev-python
parentVersion bump. (diff)
downloadgentoo-2-f3c0cd7d9d2cbd7189093652957f013587c453d4.tar.gz
gentoo-2-f3c0cd7d9d2cbd7189093652957f013587c453d4.tar.bz2
gentoo-2-f3c0cd7d9d2cbd7189093652957f013587c453d4.zip
bump; update deps, drop redundant patches, put doc build in correct phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-1.3.0.ebuild5
-rw-r--r--dev-python/pylint/pylint-1.3.1.ebuild56
3 files changed, 65 insertions, 4 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index d682da146471..7ba21157c71b 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.110 2014/08/05 02:52:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.111 2014/09/10 13:23:50 idella4 Exp $
+
+*pylint-1.3.1 (10 Sep 2014)
+
+ 10 Sep 2014; Ian Delaney <idella4@gentoo.org> +pylint-1.3.1.ebuild,
+ pylint-1.3.0.ebuild:
+ bump; update deps, drop redundant patches, put doc build in correct phase
05 Aug 2014; Ian Delaney <idella4@gentoo.org> pylint-1.3.0.ebuild:
correction to doc install, fixes Bug #519034
diff --git a/dev-python/pylint/pylint-1.3.0.ebuild b/dev-python/pylint/pylint-1.3.0.ebuild
index 7f5199b59584..9ec8f8068e58 100644
--- a/dev-python/pylint/pylint-1.3.0.ebuild
+++ b/dev-python/pylint/pylint-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.3.0.ebuild,v 1.2 2014/08/05 02:52:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.3.0.ebuild,v 1.3 2014/09/10 13:23:50 idella4 Exp $
EAPI=5
@@ -28,10 +28,9 @@ PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )
# Usual. Requ'd for impl specific failures in test phase
DISTUTILS_IN_SOURCE_BUILD=1
-python_prepare_all() {
+python_compile_all() {
# selection of straight html triggers a trivial annoying bug, we skirt it
use doc && emake -C doc singlehtml
- distutils-r1_python_prepare_all
}
python_test() {
diff --git a/dev-python/pylint/pylint-1.3.1.ebuild b/dev-python/pylint/pylint-1.3.1.ebuild
new file mode 100644
index 000000000000..6c3f3dbfc9bf
--- /dev/null
+++ b/dev-python/pylint/pylint-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.3.1.ebuild,v 1.1 2014/09/10 13:23:50 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
+ ~dev-python/astroid-1.2.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( "${RDEPEND}" )"
+
+# Usual. Requ'd for impl specific failures in test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && emake -C doc singlehtml
+}
+
+python_test() {
+ # Test suite appears not to work under Python 3.
+ # https://bitbucket.org/logilab/pylint/issue/240/
+ local msg="Test suite broken with ${EPYTHON}"
+ if python_is_python3; then
+ einfo "${msg}"
+ return 0
+ fi
+
+ pytest || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}