summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-12 07:48:02 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-12 07:48:02 +0000
commitf6123c84eef245301432e72f6a5311272590df63 (patch)
tree69d73adc7ac50df031566a62f49108dc9a98aed1 /dev-python
parentAdd missing ~x86 keyword. (diff)
downloadgentoo-2-f6123c84eef245301432e72f6a5311272590df63.tar.gz
gentoo-2-f6123c84eef245301432e72f6a5311272590df63.tar.bz2
gentoo-2-f6123c84eef245301432e72f6a5311272590df63.zip
Drop old; add pypy support
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-sqlparse/ChangeLog6
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.11.ebuild33
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.12.ebuild45
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild13
4 files changed, 13 insertions, 84 deletions
diff --git a/dev-python/python-sqlparse/ChangeLog b/dev-python/python-sqlparse/ChangeLog
index 770080a3470b..48e465ba6d80 100644
--- a/dev-python/python-sqlparse/ChangeLog
+++ b/dev-python/python-sqlparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-sqlparse
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.45 2015/03/08 23:57:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.46 2015/03/12 07:48:02 jlec Exp $
+
+ 12 Mar 2015; Justin Lecher <jlec@gentoo.org> -python-sqlparse-0.1.11.ebuild,
+ -python-sqlparse-0.1.12.ebuild, python-sqlparse-0.1.13.ebuild:
+ Drop old; add pypy support
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> python-sqlparse-0.1.13.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.11.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.11.ebuild
deleted file mode 100644
index 2751cdb40c64..000000000000
--- a/dev-python/python-sqlparse/python-sqlparse-0.1.11.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.11.ebuild,v 1.2 2014/08/27 08:43:43 maksbotan Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A non-validating SQL parser module for Python"
-HOMEPAGE="http://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
-SRC_URI="https://github.com/andialbrecht/sqlparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD-2"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-DISTUTILS_IN_SOURCE_BUILD=1 # Required for running tests
-
-S="${WORKDIR}"/${P#python-}
-
-python_test() {
- if python_is_python3; then
- 2to3 -w --no-diffs -n tests/ sqlparse/
- py.test ./tests || die "testsuite failed ${EPYTHON}"
- else
- py.test tests || die "testsuite failed under ${EPYTHON}"
- fi
-}
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.12.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.12.ebuild
deleted file mode 100644
index 55e3e7596f22..000000000000
--- a/dev-python/python-sqlparse/python-sqlparse-0.1.12.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.12.ebuild,v 1.3 2014/10/24 14:38:49 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A non-validating SQL parser module for Python"
-HOMEPAGE="http://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
-SRC_URI="https://github.com/andialbrecht/sqlparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~x86 ~ppc ~ppc64 ~amd64-linux ~x86-linux"
-LICENSE="BSD-2"
-IUSE="doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}] )"
-# Required for running tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}"/${P#python-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- if python_is_python3; then
- 2to3 -w --no-diffs -n tests/ sqlparse/
- py.test ./tests || die "testsuite failed ${EPYTHON}"
- else
- py.test tests || die "testsuite failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild
index 445ebbe7829a..59bb66f9235b 100644
--- a/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild
+++ b/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild,v 1.8 2015/03/08 23:57:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild,v 1.9 2015/03/12 07:48:02 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
inherit distutils-r1
@@ -17,9 +17,12 @@ KEYWORDS="amd64 arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
LICENSE="BSD-2"
IUSE="doc examples test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}] )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
# Required for running tests
DISTUTILS_IN_SOURCE_BUILD=1