summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-20 00:13:26 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-20 00:13:26 +0000
commitfcf3541544737e23cfc0685546142b85681eb169 (patch)
tree4ce7a464558c77487b1168fb941a818aa09b9b62 /dev-python
parentAdd prefix keywords, support (diff)
downloadgentoo-2-fcf3541544737e23cfc0685546142b85681eb169.tar.gz
gentoo-2-fcf3541544737e23cfc0685546142b85681eb169.tar.bz2
gentoo-2-fcf3541544737e23cfc0685546142b85681eb169.zip
Add prefix keywords, support
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog5
-rw-r--r--dev-python/PyQt4/PyQt4-4.7.ebuild19
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index f680e640fa1d..9946673a60a5 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.103 2010/01/15 15:15:44 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.104 2010/01/20 00:13:26 abcd Exp $
+
+ 20 Jan 2010; Jonathan Callen <abcd@gentoo.org> PyQt4-4.7.ebuild:
+ Add prefix keywords, support
*PyQt4-4.7 (15 Jan 2010)
diff --git a/dev-python/PyQt4/PyQt4-4.7.ebuild b/dev-python/PyQt4/PyQt4-4.7.ebuild
index 0838d082cdd8..0aa8906351b4 100644
--- a/dev-python/PyQt4/PyQt4-4.7.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.7.ebuild,v 1.1 2010/01/15 15:15:44 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.7.ebuild,v 1.2 2010/01/20 00:13:26 abcd Exp $
EAPI="2"
PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
@@ -17,7 +17,7 @@ SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz
SLOT="0"
LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="X assistant +dbus debug doc examples kde multimedia opengl phonon sql svg webkit xmlpatterns"
DEPEND="=dev-python/sip-4.10*
@@ -51,12 +51,19 @@ PATCHES=(
)
src_prepare() {
+ use prefix || EPREFIX=
+
if ! use dbus; then
sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
"${S}"/configure.py || die
fi
qt4-r2_src_prepare
+
+ # Use proper include dir
+ sed -e "s|/usr/include|${EPREFIX}/usr/include|g" \
+ -i configure.py
+
python_copy_sources
preparation() {
@@ -74,12 +81,14 @@ pyqt4_use_enable() {
}
src_configure() {
+ use prefix || EPREFIX=
+
configuration() {
local myconf="$(PYTHON) configure.py
--confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
+ --bindir=${EPREFIX}/usr/bin
+ --destdir=${EPREFIX}$(python_get_sitedir)
+ --sipdir=${EPREFIX}/usr/share/sip
--qsci-api
$(use debug && echo '--debug')
--enable=QtCore