summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-08-27 11:26:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-08-27 11:26:53 +0000
commit32d807c7ed4299af73068aad1153fba227ba26e9 (patch)
tree87a8d1989b0a1bdf90710e0024ca3657fcdcbe44 /dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild
parentApply oracle/ldap fix for bug #180391 (diff)
downloadgentoo-2-32d807c7ed4299af73068aad1153fba227ba26e9.tar.gz
gentoo-2-32d807c7ed4299af73068aad1153fba227ba26e9.tar.bz2
gentoo-2-32d807c7ed4299af73068aad1153fba227ba26e9.zip
A patch to fix proxy passing via argument
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild')
-rw-r--r--dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild b/dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..2f46843eae51
--- /dev/null
+++ b/dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.2.1-r1.ebuild,v 1.1 2007/08/27 11:26:53 caleb Exp $
+
+inherit eutils
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test debug"
+
+RDEPEND="~dev-cpp/Ice-3.2.1
+ >=dev-lang/ruby-1.8.4"
+
+DEPEND="${RDEPEND}
+ test? ( >=dev-lang/python-2.4 )"
+
+src_unpack() {
+# export ICE_HOME=/usr
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/${P}-Makefile.patch
+ epatch ${FILESDIR}/${P}-ice_type.patch
+
+ mkdir -p ${S}/bin
+ mkdir -p ${S}/lib
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ cd ${S}
+# export ICE_HOME=/usr
+ make || die "Died during make"
+}
+
+src_install() {
+# export ICE_HOME=/usr
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+# export ICE_HOME=/usr
+ make test || die "Test failed"
+}