summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-05 17:12:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-05 17:12:52 +0000
commit84d7e0ab9603a7962152c181f51749b3404230df (patch)
tree475e4327e77b083dc654c6205fbd53f65c8c29ae /dev-ruby/actionmailer
parentMask kde-base/ksecrets as it's alpha code (diff)
downloadgentoo-2-84d7e0ab9603a7962152c181f51749b3404230df.tar.gz
gentoo-2-84d7e0ab9603a7962152c181f51749b3404230df.tar.bz2
gentoo-2-84d7e0ab9603a7962152c181f51749b3404230df.zip
Make sure to fix the spec to allow using mail-2.4.0 or it would fail with bundler.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog9
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.1.4-r1.ebuild (renamed from dev-ruby/actionmailer/actionmailer-3.1.4.ebuild)4
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 9e631e6893a8..b7864d7e750f 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.182 2012/04/04 11:47:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.183 2012/04/05 17:12:52 flameeyes Exp $
+
+*actionmailer-3.1.4-r1 (05 Apr 2012)
+
+ 05 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +actionmailer-3.1.4-r1.ebuild, -actionmailer-3.1.4.ebuild:
+ Make sure to fix the spec to allow using mail-2.4.0 or it would fail with
+ bundler.
*actionmailer-3.1.4 (04 Apr 2012)
diff --git a/dev-ruby/actionmailer/actionmailer-3.1.4.ebuild b/dev-ruby/actionmailer/actionmailer-3.1.4-r1.ebuild
index c9bc8d68effe..19bc70b867f2 100644
--- a/dev-ruby/actionmailer/actionmailer-3.1.4.ebuild
+++ b/dev-ruby/actionmailer/actionmailer-3.1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.4.ebuild,v 1.1 2012/04/04 11:47:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.4-r1.ebuild,v 1.1 2012/04/05 17:12:52 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
@@ -34,4 +34,6 @@ all_ruby_prepare() {
# Set test environment to our hand.
rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
}